[package] libnl-tiny: port upstream bugfix 8ee16e6688657886f591f0841cb8e892743ecf2a...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Apr 2012 05:32:32 +0000 (05:32 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Apr 2012 05:32:32 +0000 (05:32 +0000)
SVN-Revision: 31155

package/libnl-tiny/Makefile
package/libnl-tiny/src/socket.c

index f96424928362031f1ff246e8115e46df31553657..37ac26fe9c3134bd528c0bdda19578b98f391eb1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl-tiny
 PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index 6fe56fdc537e60c4e9bd104ddba951018fcbf763..1429825e636e99f46e12ccee41dbf051c49a894c 100644 (file)
@@ -59,7 +59,7 @@ static void release_local_port(uint32_t port)
                return;
        
        nr = port >> 22;
-       used_ports_map[nr / 32] &= ~((nr % 32) + 1);
+       used_ports_map[nr / 32] &= ~(1 << nr % 32);
 }
 
 /**