[package] base-files: kill remaining processes after running user hooks (#10461)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 19 Nov 2011 16:50:25 +0000 (16:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 19 Nov 2011 16:50:25 +0000 (16:50 +0000)
SVN-Revision: 29256

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 9b3745ba98c0435ea375322423ddd9db1aee3bf7..b2d1d352a5bb5d59dad59e15b2b76130a35d3c0a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=97
+PKG_RELEASE:=98
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index d251cc914f9210f76864ca7273837b7fa99c13b4..cf79114cbb2802f45740ff78ddb62a78add7f163 100755 (executable)
@@ -128,12 +128,12 @@ else
        export SAVE_CONFIG=0
 fi
 
+run_hooks "" $sysupgrade_pre_upgrade
+
 kill_remaining TERM
 sleep 3
 kill_remaining KILL
 
-run_hooks "" $sysupgrade_pre_upgrade
-
 if [ -n "$(rootfs_type)" ]; then
        v "Switching to ramdisk..."
        run_ramfs '. /etc/functions.sh; include /lib/upgrade; do_upgrade'