Added support for : save-password( --enable-password-save), smaller executable (...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Feb 2006 07:31:29 +0000 (07:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Feb 2006 07:31:29 +0000 (07:31 +0000)
SVN-Revision: 3284

openwrt/package/openvpn/Config.in
openwrt/package/openvpn/Makefile

index 860a39f03472546f353dffc18543df2a0484cf1f..3feffa3016b278382673b2195fc2fecb232ac9f0 100644 (file)
@@ -38,4 +38,16 @@ config BR2_COMPILE_OPENVPN_WITH_LZO
        depends BR2_PACKAGE_OPENVPN
        select BR2_PACKAGE_LIBLZO
 
+config BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE
+       prompt "Enable password saving"
+       bool
+       default y
+       depends BR2_PACKAGE_OPENVPN
+
+config BR2_COMPILE_OPENVPN_WITH_SMALL
+       prompt "Enable smaller executable size (disable OCC, usage message, and verb 4 parm list)"
+       bool
+       default n
+       depends BR2_PACKAGE_OPENVPN
+
 endmenu
index e5e1275841a50b9215ca1d66323f7996d018fe3b..5ae1a31200b94cdbbf0dc628837063b7131182ac 100644 (file)
@@ -38,6 +38,12 @@ endif
 ifneq ($(BR2_COMPILE_OPENVPN_WITH_HTTP),y)
 DISABLE_HTTP:=--disable-http
 endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE),y)
+ENABLE_PASSWORD_SAVE:=--enable-password-save
+endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_SMALL),y)
+ENABLE_SMALL:=--enable-small
+endif
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -76,6 +82,8 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_OPENSSL) \
                  $(DISABLE_SERVER) \
                  $(DISABLE_HTTP) \
+                 $(ENABLE_PASSWORD_SAVE) \
+                 $(ENABLE_SMALL) \
        );
        touch $(PKG_BUILD_DIR)/.configured