[package] e2fsprogs: fix blkid dependencies (#9377)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 5 Jul 2011 12:40:56 +0000 (12:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 5 Jul 2011 12:40:56 +0000 (12:40 +0000)
SVN-Revision: 27459

package/e2fsprogs/Makefile

index 3a6a966937e590ece780be44a6daa9c4f7a7259d..aac0c5e5be3e9e031c7439abc1108f9a3ff8556c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=e2fsprogs
 PKG_VERSION:=1.41.12
 PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
@@ -29,7 +29,7 @@ $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3/4 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread
+  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread +libcom_err
 endef
 
 define Package/e2fsprogs/description
@@ -85,6 +85,17 @@ define Package/libext2fs/description
 libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
 endef
 
+define Package/libcom_err
+$(call Package/e2fsprogs/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Common error description library
+endef
+
+define Package/libcom_err/description
+libcom_err is a library providing common error descriptions
+endef
+
 define Package/tune2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
@@ -106,7 +117,7 @@ endef
 define Package/blkid
 $(call Package/e2fsprogs)
   TITLE:=Command-line utility to locate/print block device attributes
-  DEPENDS:=+libuuid +libblkid
+  DEPENDS:=+libuuid +libblkid +libext2fs +libcom_err +libpthread
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -156,13 +167,18 @@ define Package/e2fsprogs/install
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext4
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libe2p.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/lib/functions/fsck
        $(INSTALL_DATA) ./files/e2fsck.sh $(1)/lib/functions/fsck/
        $(INSTALL_DATA) ./files/e2fsck.conf $(1)/etc/e2fsck.conf
 endef
 
+define Package/libcom_err/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so.* $(1)/usr/lib/
+endef
+
 define Package/libuuid/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
@@ -208,6 +224,7 @@ $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,uuidgen))
 $(eval $(call BuildPackage,libblkid))
 $(eval $(call BuildPackage,libext2fs))
+$(eval $(call BuildPackage,libcom_err))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))