tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)
authorAlexandros C. Couloumbis <alex@ozo.com>
Tue, 27 Jul 2010 17:21:30 +0000 (17:21 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Tue, 27 Jul 2010 17:21:30 +0000 (17:21 +0000)
SVN-Revision: 22397

tools/quilt/Makefile
tools/quilt/patches/100-patch_2.6.1_version.patch [new file with mode: 0644]

index b973eb404f59aad28711843827f7bb2d53f416cf..221398f29b716c502d4784e98bb782416785b144 100644 (file)
@@ -16,6 +16,7 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Configure
+       cd $(HOST_BUILD_DIR) && autoconf
        $(call Host/Configure/Default)
        [ -f $(HOST_BUILD_DIR)/Makefile ]
 endef
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644 (file)
index 0000000..84f2753
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+   set -- `$PATCH --version 2> /dev/null`
+-  patch_version=$2
++  test $2 == "patch" && patch_version=$3 || patch_version=$2
+   AC_MSG_RESULT($patch_version)
+   saved_IFS=$IFS; IFS='.'
+   set -- $patch_version