fix libelf build
authorFelix Fietkau <nbd@openwrt.org>
Thu, 13 Oct 2005 12:42:21 +0000 (12:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 13 Oct 2005 12:42:21 +0000 (12:42 +0000)
SVN-Revision: 2103

openwrt/package/libelf/Makefile

index 537c468fde12c1e058a3828b01711bdbcde9c0dc..02ea765b0ef6736e446a9129353083419068b21c 100644 (file)
@@ -27,6 +27,11 @@ $(PKG_BUILD_DIR)/.configured:
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                mr_cv_target_elf=yes \
+               libelf_64bit=yes \
+               libelf_cv_struct_elf64_ehdr=yes \
+               libelf_cv_type_elf64_addr=no \
+               libelf_cv_struct_elf64_rel=yes \
+               ac_cv_sizeof_long_long=8 \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -49,6 +54,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_NLS) \
                  --enable-shared \
                  --enable-static \
+                 --enable-elf64=yes \
        );
        touch $@