kirkwood: add Pogoplug E02 kernel support for 3.14
authorLuka Perkov <luka@openwrt.org>
Fri, 23 May 2014 08:16:56 +0000 (08:16 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 23 May 2014 08:16:56 +0000 (08:16 +0000)
This also fixes a typo in the UBIFS_OPTS

Signed-off-by: Felix Kaechele <heffer@fedoraproject.org>
SVN-Revision: 40827

target/linux/kirkwood/patches-3.14/150-pogoplug_e02.patch [new file with mode: 0644]
target/linux/kirkwood/profiles/120-pogoplug.mk

diff --git a/target/linux/kirkwood/patches-3.14/150-pogoplug_e02.patch b/target/linux/kirkwood/patches-3.14/150-pogoplug_e02.patch
new file mode 100644 (file)
index 0000000..44b4c52
--- /dev/null
@@ -0,0 +1,127 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -112,6 +112,7 @@ dtb-$(CONFIG_ARCH_KIRKWOOD) += kirkwood-
+       kirkwood-nsa310a.dtb \
+       kirkwood-openblocks_a6.dtb \
+       kirkwood-openblocks_a7.dtb \
++      kirkwood-pogo_e02.dtb \
+       kirkwood-sheevaplug.dtb \
+       kirkwood-sheevaplug-esata.dtb \
+       kirkwood-topkick.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
+@@ -0,0 +1,114 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++      model = "Cloud Engines Pogoplug E02";
++      compatible = "cloudengines,pogoe02", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++      memory {
++              device_type = "memory";
++              reg = <0x00000000 0x10000000>;
++      };
++
++      chosen {
++              bootargs = "console=ttyS0,115200n8 earlyprintk";
++      };
++
++      ocp@f1000000 {
++              pinctrl: pinctrl@10000 {
++                      pmx_usb_power_enable: pmx-usb-power-enable {
++                              marvell,pins = "mpp29";
++                              marvell,function = "gpio";
++                      };
++                      pmx_led_green: pmx-led_green {
++                              marvell,pins = "mpp48";
++                              marvell,function = "gpio";
++                      };
++                      pmx_led_orange: pmx-led_orange {
++                              marvell,pins = "mpp49";
++                              marvell,function = "gpio";
++                      };
++              };
++              serial@12000 {
++                      status = "ok";
++              };
++      };
++      gpio-leds {
++              compatible = "gpio-leds";
++              pinctrl-0 = < &pmx_usb_power_enable &pmx_led_orange
++                            &pmx_led_green >;
++              pinctrl-names = "default";
++
++              health {
++                      label = "status:green:health";
++                      gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++                      default-state = "keep";
++              };
++              fault {
++                      label = "status:orange:fault";
++                      gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
++              };
++      };
++      regulators {
++              compatible = "simple-bus";
++              #address-cells = <1>;
++              #size-cells = <0>;
++              pinctrl-0 = <&pmx_usb_power_enable>;
++              pinctrl-names = "default";
++
++              usb_power: regulator@1 {
++                      compatible = "regulator-fixed";
++                      reg = <1>;
++                      regulator-name = "USB Power";
++                      regulator-min-microvolt = <5000000>;
++                      regulator-max-microvolt = <5000000>;
++                      enable-active-high;
++                      regulator-always-on;
++                      regulator-boot-on;
++                      gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++              };
++      };
++};
++
++&nand {
++      chip-delay = <40>;
++      status = "okay";
++
++      partition@0 {
++              label = "u-boot";
++              reg = <0x0000000 0x100000>;
++              read-only;
++      };
++
++      partition@100000 {
++              label = "uImage";
++              reg = <0x0100000 0x400000>;
++      };
++
++      partition@500000 {
++              label = "pogoplug";
++              reg = <0x0500000 0x2000000>;
++      };
++
++      partition@2500000 {
++              label = "root";
++              reg = <0x02500000 0x5b00000>;
++      };
++};
++
++&mdio {
++      status = "okay";
++
++      ethphy0: ethernet-phy@0 {
++              reg = <0>;
++      };
++};
++
++&eth0 {
++      status = "okay";
++      ethernet0-port@0 {
++              phy-handle = <&ethphy0>;
++      };
++};
index 47672f1114dc0e1f72b4e536bbe42b7c0a5581e3..d712dcb6188405ee8608597eb8586c2bd551164b 100644 (file)
@@ -15,7 +15,7 @@ define Profile/POGOE02/Description
  Package set compatible with Cloud Engines Pogoplug E02 board.
 endef
 
-POGOE02_UBIFS_OPTS:="-m 2048 -e 128KiB -c 4096"
+POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
 POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,POGOE02))