package/kernel: enable kmod-ata-core & kmod-scsi-core on x86
authorNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 19:16:27 +0000 (19:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 19:16:27 +0000 (19:16 +0000)
SVN-Revision: 28662

package/kernel/modules/block.mk
package/kernel/modules/firewire.mk
package/kernel/modules/usb.mk

index 41509b01b8c01b4ff2cbf765d495df28a6186f35..6d67e72f72febae61e29999db6e46894afd9c4fb 100644 (file)
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax||!TARGET_x86)
+  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax)
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
   AUTOLOAD:=$(call AutoLoad,21,libata,1)
@@ -36,7 +36,7 @@ $(eval $(call KernelPackage,ata-core))
 
 define AddDepends/ata
   SUBMENU:=$(BLOCK_MENU)
-  DEPENDS+=!TARGET_x86:kmod-ata-core $(1)
+  DEPENDS+=kmod-ata-core $(1)
 endef
 
 
@@ -612,7 +612,6 @@ $(eval $(call KernelPackage,nbd))
 define KernelPackage/scsi-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SCSI device support
-  DEPENDS:=@!TARGET_x86
   KCONFIG:= \
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
@@ -628,7 +627,7 @@ $(eval $(call KernelPackage,scsi-core))
 define KernelPackage/scsi-generic
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for SCSI generic
-  DEPENDS:=+!TARGET_x86:kmod-scsi-core
+  DEPENDS:=+kmod-scsi-core
   KCONFIG:= \
        CONFIG_CHR_DEV_SG
   FILES:= \
@@ -642,7 +641,7 @@ $(eval $(call KernelPackage,scsi-generic))
 define KernelPackage/scsi-cdrom
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for CD / DVD drives
-  DEPENDS:=+!TARGET_x86:kmod-scsi-core
+  DEPENDS:=+kmod-scsi-core
   KCONFIG:= \
     CONFIG_BLK_DEV_SR \
     CONFIG_BLK_DEV_SR_VENDOR=n
index 10d144ce756f6f3af41fbe5686e6c60c809b7363..0c8f75cdf99b07249829987b7766eedee7293528 100644 (file)
@@ -130,7 +130,7 @@ $(eval $(call KernelPackage,firewire-ohci))
 define KernelPackage/firewire-sbp2
   SUBMENU:=$(FIREWIRE_MENU)
   TITLE:=Support for SBP-2 devices over FireWire
-  DEPENDS:=kmod-firewire +!TARGET_x86:kmod-scsi-core
+  DEPENDS:=kmod-firewire +kmod-scsi-core
   KCONFIG:=CONFIG_FIREWIRE_SBP2
   FILES:=$(LINUX_DIR)/drivers/firewire/firewire-sbp2.ko
   AUTOLOAD:=$(call AutoLoad,50,firewire-sbp2)
index 45ad0882fd6e01cf32683a8fd201d40732360208..b72a34628611b7b9ab43e1b6b34b2aab61688aeb 100644 (file)
@@ -578,7 +578,7 @@ $(eval $(call KernelPackage,usb-serial-option))
 
 define KernelPackage/usb-storage
   TITLE:=USB Storage support
-  DEPENDS:= +!TARGET_x86:kmod-scsi-core
+  DEPENDS:= +kmod-scsi-core
   KCONFIG:=CONFIG_USB_STORAGE
   FILES:=$(LINUX_DIR)/drivers/usb/storage/usb-storage.ko
   AUTOLOAD:=$(call AutoLoad,60,usb-storage,1)