add libdaemon package
authorNicolas Thill <nico@openwrt.org>
Tue, 23 Aug 2005 08:10:02 +0000 (08:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 23 Aug 2005 08:10:02 +0000 (08:10 +0000)
SVN-Revision: 1731

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/libdaemon/Config.in [new file with mode: 0644]
openwrt/package/libdaemon/Makefile [new file with mode: 0644]
openwrt/package/libdaemon/ipkg/libdaemon.control [new file with mode: 0644]

index a32c2bee610928415d2ee66f41e87fa6e9b05aef..6259d2d63976c01d38dd1081ae2d522448e59ef5 100644 (file)
@@ -113,6 +113,7 @@ source "package/cgilib/Config.in"
 source "package/glib/Config.in"
 source "package/libamsel/Config.in"
 source "package/libart/Config.in"
+source "package/libdaemon/Config.in"
 source "package/libdb/Config.in"
 source "package/libelf/Config.in"
 source "package/libevent/Config.in"
index 816b3760e4e3a32fb970a7056afdf3841a6682d9..1d271ffbff58b621249b396fbbb72ccebf887c5c 100644 (file)
@@ -56,6 +56,7 @@ package-$(BR2_PACKAGE_LCD4LINUX) += lcd4linux
 package-$(BR2_PACKAGE_LESS) += less
 package-$(BR2_PACKAGE_LIBAMSEL) += libamsel
 package-$(BR2_PACKAGE_LIBART) += libart
+package-$(BR2_PACKAGE_LIBDAEMON) += libdaemon
 package-$(BR2_PACKAGE_LIBDB) += libdb
 package-$(BR2_PACKAGE_LIBELF) += libelf
 package-$(BR2_PACKAGE_LIBEVENT) += libevent
diff --git a/openwrt/package/libdaemon/Config.in b/openwrt/package/libdaemon/Config.in
new file mode 100644 (file)
index 0000000..eb4b619
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LIBDAEMON
+       tristate "libdaemon - A lightweight C library that eases the writing of UNIX daemons"
+#      default m if CONFIG_DEVEL
+       default n
+       help
+         libdaemon is a lightweight C library that eases the writing of UNIX daemons. 
+         It consists of the following parts:
+         
+           * A wrapper around fork() which does the correct daemonization procedure of a process
+           * A wrapper around syslog() for simpler and compatible log output to Syslog or STDERR
+           * An API for writing PID files
+           * An API for serializing UNIX signals into a pipe for usage with select() or poll()
+           * An API for running subprocesses with STDOUT and STDERR redirected to syslog.
+         
+         APIs like these are used in most daemon software available. It is not that 
+         simple to get it done right and code duplication is not a goal.
+         
+         
+         http://0pointer.de/lennart/projects/libdaemon/
+         
diff --git a/openwrt/package/libdaemon/Makefile b/openwrt/package/libdaemon/Makefile
new file mode 100644 (file)
index 0000000..e5e58f0
--- /dev/null
@@ -0,0 +1,97 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libdaemon
+PKG_VERSION:=0.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=49cc7db480c6d7b8ca88b0db8ac275e7
+
+PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/libdaemon/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBDAEMON,libdaemon,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               ac_cv_func_setpgrp_void=yes \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+                 --disable-rpath \
+                 --with-gnu-ld \
+                 --disable-lynx \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_LIBDAEMON):
+       install -d -m0755 $(IDIR_LIBDAEMON)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libdaemon.so.* $(IDIR_LIBDAEMON)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBDAEMON)
+       $(IPKG_BUILD) $(IDIR_LIBDAEMON) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libdaemon.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/libdaemon $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libdaemon.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libdaemon.so* $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libdaemon.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
+       $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libdaemon.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/include/libdaemon \
+               $(STAGING_DIR)/usr/lib/libdaemon.a \
+               $(STAGING_DIR)/usr/lib/libdaemon.so* \
+               $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/libdaemon/ipkg/libdaemon.control b/openwrt/package/libdaemon/ipkg/libdaemon.control
new file mode 100644 (file)
index 0000000..caf84c2
--- /dev/null
@@ -0,0 +1,6 @@
+Package: libdaemon
+Priority: optional
+Section: libs
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/libdaemon/
+Description: A lightweight C library that eases the writing of UNIX daemons.