Convert radvd to new packaging style
authorNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 09:47:32 +0000 (09:47 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 09:47:32 +0000 (09:47 +0000)
SVN-Revision: 904

openwrt/package/radvd/Makefile
openwrt/package/radvd/files/S51radvd [deleted file]
openwrt/package/radvd/files/radvd.conf [new file with mode: 0644]
openwrt/package/radvd/files/radvd.conf.example [deleted file]
openwrt/package/radvd/files/radvd.init [new file with mode: 0644]
openwrt/package/radvd/ipkg/radvd.conffiles [new file with mode: 0644]
openwrt/package/radvd/ipkg/radvd.control [new file with mode: 0644]
openwrt/package/radvd/radvd.control [deleted file]

index 7de1af71165881840f13c150c1910352dd1868f0..a59a1ff6d3d32287effd1a6d755c8b814b528611 100644 (file)
@@ -1,3 +1,5 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
@@ -8,56 +10,61 @@ PKG_MD5SUM:=56ce3f8cbf5966a0d531c21813320423
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.patched
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(eval $(call PKG_template,RADVD,radvd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --with-logfile=/tmp/radvd.log \
-               --with-pidfile=/tmp/run/radvd.pid \
-               --with-configfile=/etc/radvd.conf \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --with-configfile=/etc/radvd.conf \
+                 --with-logfile=/var/log/radvd.log \
+                 --with-pidfile=/var/run/radvd.pid \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) LDFLAGS=-L$(PKG_BUILD_DIR) -C $(PKG_BUILD_DIR) radvd_LDADD=""
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
-       install -m 755 $(PKG_BUILD_DIR)/radvd $(PKG_IPK_DIR)/usr/sbin/
-       install -m 755 $(PKG_BUILD_DIR)/radvdump $(PKG_IPK_DIR)/usr/sbin/
-       install -m 755 ./files/S51radvd $(PKG_IPK_DIR)/etc/init.d/
-       install -m 644 ./files/radvd.conf.example $(PKG_IPK_DIR)/etc/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               radvd_LDADD=""
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_RADVD):
+       install -d -m0755 $(IDIR_RADVD)/etc
+       install -m0644 ./files/radvd.conf $(IDIR_RADVD)/etc/radvd.conf
+       install -d -m0755 $(IDIR_RADVD)/etc/init.d
+       install -m0755 ./files/radvd.init $(IDIR_RADVD)/etc/init.d/S51radvd
+       install -d -m0755 $(IDIR_RADVD)/usr/sbin
+       install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvd $(IDIR_RADVD)/usr/sbin/
+       install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvdump $(IDIR_RADVD)/usr/sbin/
+       $(RSTRIP) $(IDIR_RADVD)
+       $(IPKG_BUILD) $(IDIR_RADVD) $(PACKAGE_DIR)
diff --git a/openwrt/package/radvd/files/S51radvd b/openwrt/package/radvd/files/S51radvd
deleted file mode 100755 (executable)
index 4bd5a18..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-    start)
-       echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
-       mkdir -p /var/run
-       /usr/sbin/radvd
-       ;;
-
-    stop)
-       killall radvd
-       echo 0 > /proc/sys/net/ipv6/conf/all/forwarding
-       ;;
-
-    restart)
-       $0 stop
-       $0 start
-       ;;
-    *)
-       echo "Usage: $0 {start|stop|restart}"
-       exit 1
-       ;;
-esac
diff --git a/openwrt/package/radvd/files/radvd.conf b/openwrt/package/radvd/files/radvd.conf
new file mode 100644 (file)
index 0000000..06d8357
--- /dev/null
@@ -0,0 +1,22 @@
+# For more examples, see the radvd documentation.
+
+interface br0
+{
+       AdvSendAdvert off;
+
+#
+# Disable Mobile IPv6 support
+#
+       AdvHomeAgentFlag off;
+
+#
+# example of a standard prefix
+#
+       prefix fec0:0:0:1::/64
+       {
+               AdvOnLink on;
+               AdvAutonomous on;
+               AdvRouterAddr off;
+       };
+
+};
diff --git a/openwrt/package/radvd/files/radvd.conf.example b/openwrt/package/radvd/files/radvd.conf.example
deleted file mode 100644 (file)
index 06d8357..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# For more examples, see the radvd documentation.
-
-interface br0
-{
-       AdvSendAdvert off;
-
-#
-# Disable Mobile IPv6 support
-#
-       AdvHomeAgentFlag off;
-
-#
-# example of a standard prefix
-#
-       prefix fec0:0:0:1::/64
-       {
-               AdvOnLink on;
-               AdvAutonomous on;
-               AdvRouterAddr off;
-       };
-
-};
diff --git a/openwrt/package/radvd/files/radvd.init b/openwrt/package/radvd/files/radvd.init
new file mode 100644 (file)
index 0000000..2d9e500
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+case "$1" in
+    start)
+       echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
+       mkdir -p /var/log
+       mkdir -p /var/run
+       /usr/sbin/radvd
+       ;;
+
+    stop)
+       killall radvd
+       echo 0 > /proc/sys/net/ipv6/conf/all/forwarding
+       ;;
+
+    restart)
+       $0 stop
+       $0 start
+       ;;
+    *)
+       echo "Usage: $0 {start|stop|restart}"
+       exit 1
+       ;;
+esac
diff --git a/openwrt/package/radvd/ipkg/radvd.conffiles b/openwrt/package/radvd/ipkg/radvd.conffiles
new file mode 100644 (file)
index 0000000..a1418c0
--- /dev/null
@@ -0,0 +1 @@
+/etc/radvd.conf
diff --git a/openwrt/package/radvd/ipkg/radvd.control b/openwrt/package/radvd/ipkg/radvd.control
new file mode 100644 (file)
index 0000000..52760ad
--- /dev/null
@@ -0,0 +1,7 @@
+Package: radvd
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: http://v6web.litech.org/radvd/
+Depends: kmod-ipv6
+Description: Routing Advertisement Daemon for IPv6
diff --git a/openwrt/package/radvd/radvd.control b/openwrt/package/radvd/radvd.control
deleted file mode 100644 (file)
index 52760ad..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: radvd
-Priority: optional
-Section: net
-Maintainer: Sebastien NOEL <me@twolife.org>
-Source: http://v6web.litech.org/radvd/
-Depends: kmod-ipv6
-Description: Routing Advertisement Daemon for IPv6