luci-app-https-dns-proxy: update to 2022-10-15-11 6245/head
authorStan Grishin <stangri@melmac.ca>
Tue, 14 Feb 2023 01:57:53 +0000 (01:57 +0000)
committerStan Grishin <stangri@melmac.ca>
Tue, 14 Feb 2023 01:58:00 +0000 (01:58 +0000)
* Makefile: change dependency from luci-mod-admin-full to luci-base
* Providers: add AdGuard and AdGuard Family
* Bugfix: update field value in CBI, fixes https://github.com/openwrt/luci/issues/6244

Signed-off-by: Stan Grishin <stangri@melmac.ca>
applications/luci-app-https-dns-proxy/Makefile
applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua [new file with mode: 0644]
applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua [new file with mode: 0644]
applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot

index ddaee4f49d26e2184ffa2f3a82b91eb878bace53..e2e0a49c9d08bdc347f2715429d16d6011dc7671 100644 (file)
@@ -5,11 +5,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=2021-11-22-7
+PKG_VERSION:=2022-10-15-11
 
 LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
 LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +https-dns-proxy
+LUCI_DEPENDS:=+luci-compat +luci-base +https-dns-proxy
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
new file mode 100644 (file)
index 0000000..0c2a4d8
--- /dev/null
@@ -0,0 +1,8 @@
+return {
+       name = "dns-family.adguard.com",
+       label = _("AdGuard (Family Protection)"),
+       resolver_url = "https://dns-family.adguard.com/dns-query",
+       bootstrap_dns = "176.103.130.132,176.103.130.134",
+       help_link = "https://adguard.com/en/adguard-dns/overview.html",
+       help_link_text = "AdGuard.com"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
new file mode 100644 (file)
index 0000000..79db202
--- /dev/null
@@ -0,0 +1,8 @@
+return {
+       name = "dns.adguard.com",
+       label = _("AdGuard (Standard)"),
+       resolver_url = "https://dns.adguard.com/dns-query",
+       bootstrap_dns = "176.103.130.130,176.103.130.131",
+       help_link = "https://adguard.com/en/adguard-dns/overview.html",
+       help_link_text = "AdGuard.com"
+}
index 1d7bcb0e8d350a2f16f44bdf92f92de31bfcdc1d..8396f46698e16b9d7d5d0a69770a10c0cf13d2b0 100644 (file)
@@ -120,7 +120,7 @@ if packageStatusCode ~= -1 then
 end
 
 c = m:section(NamedSection, "config", "https-dns-proxy", translate("Configuration"))
-d1 = c:option(ListValue, "update_dnsmasq_config", translate("Update DNSMASQ Config on Start/Stop"), translatef("If update option is selected, the 'DNS forwardings' section of %sDHCP and DNS%s will be automatically updated to use selected DoH providers (%smore information%s).", "<a href=\"" .. dispatcher.build_url("admin/network/dhcp") .. "\">", "</a>", "<a href=\"" .. readmeURL .. "#default-settings" .. "\" target=\"_blank\">", "</a>"))
+d1 = c:option(ListValue, "dnsmasq_config_update", translate("Update DNSMASQ Config on Start/Stop"), translatef("If update option is selected, the 'DNS forwardings' section of %sDHCP and DNS%s will be automatically updated to use selected DoH providers (%smore information%s).", "<a href=\"" .. dispatcher.build_url("admin/network/dhcp") .. "\">", "</a>", "<a href=\"" .. readmeURL .. "#default-settings" .. "\" target=\"_blank\">", "</a>"))
 d1:value('*', translate("Update all configs"))
 local dnsmasq_num = 0
 uci:foreach("dhcp", "dnsmasq", function(s)
index b4c2232910285870f563314e0d15df8632191efb..62da3aa64131dde4a96c45d967ea760a9329651e 100644 (file)
@@ -13,15 +13,11 @@ msgstr ""
 msgid "360 Secure DNS - CN"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns-family.lua:3
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua:3
 msgid "AdGuard (Family Protection)"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns-nonfiltering.lua:3
-msgid "AdGuard (Non-filtering)"
-msgstr ""
-
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns.lua:3
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua:3
 msgid "AdGuard (Standard)"
 msgstr ""
 
@@ -169,17 +165,14 @@ msgstr ""
 msgid "Configuration"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware-ads-social.lua:3
 #: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p3.lua:3
 msgid "ControlD (Block Malware + Ads + Social)"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware-ads.lua:3
 #: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p2.lua:3
 msgid "ControlD (Block Malware + Ads)"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware.lua:3
 #: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p1.lua:3
 msgid "ControlD (Block Malware)"
 msgstr ""
@@ -189,7 +182,6 @@ msgid "ControlD (Family)"
 msgstr ""
 
 #: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p0.lua:3
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.unfiltered.lua:3
 msgid "ControlD (Unfiltered)"
 msgstr ""
 
@@ -458,10 +450,6 @@ msgstr ""
 msgid "Tiarap Public DNS - SG"
 msgstr ""
 
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/cn.edu.tsinghua.tuna.dns.lua:3
-msgid "Tsinghua University Secure DNS - CN"
-msgstr ""
-
 #: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:65
 msgid "Unknown Provider"
 msgstr ""