* Core translation
authorSteven Barth <steven@midlink.org>
Sun, 8 Jun 2008 08:14:31 +0000 (08:14 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 8 Jun 2008 08:14:31 +0000 (08:14 +0000)
* Added license headers
* Splitted qos into separate application package

37 files changed:
applications/luci-olsr/luasrc/controller/olsr.lua
applications/luci-qos/Makefile [new file with mode: 0644]
applications/luci-qos/luasrc/controller/qos.lua [new file with mode: 0644]
applications/luci-qos/luasrc/model/cbi/qos/qos.lua [new file with mode: 0644]
contrib/package/luci/Makefile
i18n/english/luasrc/i18n/admin-core.en.lua
i18n/english/luasrc/i18n/default.en.lua
i18n/german/luasrc/i18n/admin-core.de.lua [new file with mode: 0644]
libs/cbi/luasrc/cbi.lua
libs/core/luasrc/util.lua
libs/sgi-webuci/luasrc/sgi/webuci.lua
libs/web/luasrc/dispatcher.lua
modules/admin-core/luasrc/controller/admin/index.lua
modules/admin-core/luasrc/controller/admin/network.lua
modules/admin-core/luasrc/controller/admin/services.lua
modules/admin-core/luasrc/controller/admin/status.lua
modules/admin-core/luasrc/controller/admin/system.lua
modules/admin-core/luasrc/controller/admin/uci.lua
modules/admin-core/luasrc/controller/admin/wifi.lua
modules/admin-core/luasrc/model/cbi/admin_index/luci.lua
modules/admin-core/luasrc/model/cbi/admin_network/dhcp.lua
modules/admin-core/luasrc/model/cbi/admin_network/ifaces.lua
modules/admin-core/luasrc/model/cbi/admin_network/ptp.lua
modules/admin-core/luasrc/model/cbi/admin_network/qos.lua [deleted file]
modules/admin-core/luasrc/model/cbi/admin_network/routes.lua
modules/admin-core/luasrc/model/cbi/admin_network/vlan.lua
modules/admin-core/luasrc/model/cbi/admin_services/dnsmasq.lua
modules/admin-core/luasrc/model/cbi/admin_services/dropbear.lua
modules/admin-core/luasrc/model/cbi/admin_services/httpd.lua
modules/admin-core/luasrc/model/cbi/admin_system/fstab.lua
modules/admin-core/luasrc/model/cbi/admin_system/hostname.lua
modules/admin-core/luasrc/model/cbi/admin_wifi/devices.lua
modules/admin-core/luasrc/model/cbi/admin_wifi/networks.lua
modules/freifunk/luasrc/controller/freifunk/freifunk.lua
modules/freifunk/luasrc/controller/freifunk/luciinfo.lua
modules/freifunk/luasrc/model/cbi/freifunk/contact.lua
modules/freifunk/luasrc/model/cbi/freifunk/freifunk.lua

index 24159b7cc44605587b25860c8717e98024ec3222..d795dc4ed69fc8fac345da1239db4b82699bc934 100644 (file)
@@ -1,6 +1,10 @@
 module("luci.controller.olsr", package.seeall)
 
 function index()
+       if not luci.fs.isfile("/etc/config/olsr") then
+               return
+       end
+       
        local page  = node("admin", "status", "olsr")
        page.target = call("action_index")
        page.title  = "OLSR"
diff --git a/applications/luci-qos/Makefile b/applications/luci-qos/Makefile
new file mode 100644 (file)
index 0000000..81a96f6
--- /dev/null
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk
\ No newline at end of file
diff --git a/applications/luci-qos/luasrc/controller/qos.lua b/applications/luci-qos/luasrc/controller/qos.lua
new file mode 100644 (file)
index 0000000..faddbac
--- /dev/null
@@ -0,0 +1,22 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+module("luci.controller.qos", package.seeall)
+
+function index()
+       if not luci.fs.isfile("/etc/config/qos") then
+               return
+       end
+       
+       entry({"admin", "network", "qos"}, cbi("qos/qos"), "Quality of Service")
+end
\ No newline at end of file
diff --git a/applications/luci-qos/luasrc/model/cbi/qos/qos.lua b/applications/luci-qos/luasrc/model/cbi/qos/qos.lua
new file mode 100644 (file)
index 0000000..2af820d
--- /dev/null
@@ -0,0 +1,68 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("qos", "Quality of Service", [[Mit Hilfe von QoS kann einzelnen Rechnern oder Netzwerkdiensten
+eine höhere oder niedrigere Priorität zugewiesen werden.]])
+
+s = m:section(TypedSection, "interface", "Schnittstellen")
+s.addremove = true
+
+s:option(Flag, "enabled", "aktiviert")
+
+c = s:option(ListValue, "classgroup", "Klassifizierung")
+c:value("Default", "standard")
+c.default = "Default"
+
+s:option(Flag, "overhead", "Overheadberechnung")
+
+s:option(Value, "download", "Downlink", "kb/s")
+
+s:option(Value, "upload", "Uplink", "kb/s")
+
+s = m:section(TypedSection, "classify", "Klassifizierung")
+
+s.anonymous = true
+s.addremove = true
+
+t = s:option(ListValue, "target", "Klasse")
+t:value("Priority")
+t:value("Express")
+t:value("Normal")
+t:value("Bulk")
+t.default = "Normal"
+
+s:option(Value, "srchost", "Quelladresse", "Quellhost / Quellnetz").optional = true
+s:option(Value, "dsthost", "Zieladresse", "Zielhost / Zielnetz").optional = true
+s:option(Value, "layer7", "Layer 7").optional = true
+
+p2p = s:option(ListValue, "ipp2p", "P2P")
+p2p:value("")
+p2p:value("all", "Alle")
+p2p:value("bit", "Bittorrent")
+p2p:value("dc", "DirectConnect")
+p2p:value("edk", "eDonkey")
+p2p:value("gnu", "Gnutella")
+p2p:value("kazaa", "Kazaa")
+p2p.optional = true
+
+p = s:option(ListValue, "proto", "Protokoll")
+p:value("")
+p:value("tcp", "TCP")
+p:value("udp", "UDP")
+p:value("icmp", "ICMP")
+p.optional = true
+
+s:option(Value, "ports", "Port").optional = true
+s:option(Value, "portrange", "Portbereich").optional = true
+
+return m
\ No newline at end of file
index d95d91c1d7efb651a66bf9ffbbc9637422b575d9..2e0a3120093cff3865f0ff7711824edcb07a2fe7 100644 (file)
@@ -272,6 +272,17 @@ define Package/luci-app-olsr/install
 endef
 
 
+define Package/luci-app-qos
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core +qos-scripts
+  TITLE:=Quality of Service configuration module
+endef
+
+define Package/luci-app-qos/install
+       $(call Package/luci/install/template,$(1),applications/luci-qos)
+endef
+
+
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
   DEPENDS+=+luci-sgi-haserl +iptables-mod-nat +iptables-mod-ipopt
@@ -418,6 +429,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-olsr),)
        PKG_SELECTED_MODULES+=applications/luci-olsr
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-qos),)
+       PKG_SELECTED_MODULES+=applications/luci-qos
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-splash),)
        PKG_SELECTED_MODULES+=applications/luci-splash
 endif
@@ -466,6 +480,7 @@ $(eval $(call BuildPackage,luci-mod-freifunk))
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
 $(eval $(call BuildPackage,luci-app-firewall))
 $(eval $(call BuildPackage,luci-app-olsr))
+$(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
 
index 1c2d0365911fb479d18c2d401ab5946eb365f006..c5d9e7db01bc5bc9b61bb17fdda6a8d91e25a236 100644 (file)
@@ -145,3 +145,39 @@ a_w_radiusport = "Radius-Port"
 a_w_apisolation = "AP-Isolation"
 a_w_apisolation1 = "Prevents Client to Client communication"
 a_w_hideessid = "Hide ESSID"
+
+dhcp_desc = "Dnsmasq is a combined DHCP-Server and DNS-Forwarder for NAT firewalls"
+dhcp_dnsmasq_domainneeded = "Domain required"
+dhcp_dnsmasq_domainneeded_desc = "Don't forward DNS-Requests without DNS-Name"
+dhcp_dnsmasq_authoritative = "Authoritative"
+dhcp_dnsmasq_authoritative_desc = "This is the only DHCP in the local network"
+dhcp_dnsmasq_boguspriv = "Filter private"
+dhcp_dnsmasq_boguspriv_desc = "Don't forward reverse lookups for local networks"
+dhcp_dnsmasq_filterwin2k = "Filter useless"
+dhcp_dnsmasq_filterwin2k_desc = "filter useless DNS-queries of Windows-systems"
+dhcp_dnsmasq_localisequeries = "Localise queries"
+dhcp_dnsmasq_localisequeries_desc = "localises the hostname depending on its subnet"
+dhcp_dnsmasq_local = "Local Server"
+dhcp_dnsmasq_domain = "Local Domain"
+dhcp_dnsmasq_expandhosts = "Expand Hosts"
+dhcp_dnsmasq_expandhosts_desc = "adds domain names to hostentries in the resolv file"
+dhcp_dnsmasq_nonegcache = "don't cache unknown"
+dhcp_dnsmasq_nonegcache_desc = "prevents caching of negative DNS-replies"
+dhcp_dnsmasq_readethers = "Use /etc/ethers"
+dhcp_dnsmasq_readethers_desc = "Read /etc/ethers to configure the DHCP-Server" 
+dhcp_dnsmasq_leasefile = "Leasefile"
+dhcp_dnsmasq_leasefile_desc = "file where given DHCP-leases will be stored"
+dhcp_dnsmasq_resolvfile = "Resolvfile"
+dhcp_dnsmasq_resolvfile_desc = "local DNS file"
+dhcp_dnsmasq_nohosts = "Ignore /etc/hosts"
+dhcp_dnsmasq_strictorder = "Strict order"
+dhcp_dnsmasq_strictorder_desc = "DNS-Server will be queried in the order of the resolvfile"
+dhcp_dnsmasq_logqueries = "Log queries"
+dhcp_dnsmasq_noresolv = "Ignore resolve file"
+dhcp_dnsmasq_dnsforwardmax = "concurrent queries"
+dhcp_dnsmasq_port = "DNS-Port"
+dhcp_dnsmasq_ednspacket_max = "max. EDNS.0 paket size"
+dhcp_dnsmasq_dhcpleasemax = "max. DHCP-Leases"
+dhcp_dnsmasq_addnhosts = "additional hostfile"
+dhcp_dnsmasq_queryport = "query port"
+
index 3009d308eba1b87f878288ef632cf2697dbf122d..b9933216c6d31b1c9421f4413536ac4c02628464 100644 (file)
@@ -60,6 +60,7 @@ revert = "Revert"
 
 save = "Save"
 services = "Services"
+settings = "Settings"
 statistics = "Statistics"
 syslog = "System Log"
 system = "System"
diff --git a/i18n/german/luasrc/i18n/admin-core.de.lua b/i18n/german/luasrc/i18n/admin-core.de.lua
new file mode 100644 (file)
index 0000000..8b1cb3b
--- /dev/null
@@ -0,0 +1,34 @@
+dhcp_desc = "Dnsmasq ist ein kombinierter DHCP-Server und DNS-Forwarder für NAT-Firewalls."
+dhcp_dnsmasq_domainneeded = "Anfragen nur mit Domain"
+dhcp_dnsmasq_domainneeded_desc = "Anfragen ohne Domainnamen nicht weiterleiten"
+dhcp_dnsmasq_authoritative = "Authoritativ"
+dhcp_dnsmasq_authoritative_desc = "Dies ist der einzige DHCP im lokalen Netz"
+dhcp_dnsmasq_boguspriv = "Private Anfragen filtern"
+dhcp_dnsmasq_boguspriv_desc = "Reverse DNS-Anfragen für lokale Netze nicht weiterleiten"
+dhcp_dnsmasq_filterwin2k = "Windowsanfragen filtern"
+dhcp_dnsmasq_filterwin2k_desc = "nutzlose DNS-Anfragen aktueller Windowssysteme filtern"
+dhcp_dnsmasq_localisequeries = "Lokalisiere Anfragen"
+dhcp_dnsmasq_localisequeries_desc = "Gibt die Adresse eines Hostnamen entsprechend seines Subnetzes zurück"
+dhcp_dnsmasq_local = "Lokale Server"
+dhcp_dnsmasq_domain = "Lokale Domain"
+dhcp_dnsmasq_expandhosts = "Erweitere Hosts"
+dhcp_dnsmasq_expandhosts_desc = "Fügt Domainnamen zu einfachen Hosteinträgen in der Resolvdatei hinzu"
+dhcp_dnsmasq_nonegcache = "Unbekannte nicht cachen"
+dhcp_dnsmasq_nonegcache_desc = "Negative DNS-Antworten nicht zwischenspeichern"
+dhcp_dnsmasq_readethers = "Verwende /etc/ethers"
+dhcp_dnsmasq_readethers_desc = "Lese Informationen aus /etc/ethers um den DHCP-Server zu konfigurieren" 
+dhcp_dnsmasq_leasefile = "Leasedatei"
+dhcp_dnsmasq_leasefile_desc = "Speicherort für vergebenen DHCP-Adressen"
+dhcp_dnsmasq_resolvfile = "Resolvdatei"
+dhcp_dnsmasq_resolvfile_desc = "Lokale DNS-Datei"
+dhcp_dnsmasq_nohosts = "Ignoriere /etc/hosts"
+dhcp_dnsmasq_strictorder = "Strikte Reihenfolge"
+dhcp_dnsmasq_strictorder_desc = "DNS-Server werden strikt der Reihenfolge in der Resolvdatei nach abgefragt"
+dhcp_dnsmasq_logqueries = "Schreibe Abfragelog"
+dhcp_dnsmasq_noresolv = "Ignoriere Resolvdatei"
+dhcp_dnsmasq_dnsforwardmax = "gleichzeitige Abfragen"
+dhcp_dnsmasq_port = "DNS-Port"
+dhcp_dnsmasq_ednspacket_max = "max. EDNS.0 Paketgröße"
+dhcp_dnsmasq_dhcpleasemax = "max. DHCP-Leases"
+dhcp_dnsmasq_addnhosts = "Zusätzliche Hostdatei"
+dhcp_dnsmasq_queryport = "Abfrageport"
index d6a5cca0562138039c3ca839aac9c32443594bd6..fbd235595fbafc43f7ed9ae4ca96fa26aae19bdf 100644 (file)
@@ -579,9 +579,6 @@ end
 --[[
 Value - A one-line value
        maxlength:      The maximum length
-       isnumber:       The value must be a valid (floating point) number
-       isinteger:  The value must be a valid integer
-       ispositive: The value must be positive (and a number)
 ]]--
 Value = class(AbstractValue)
 
@@ -590,8 +587,6 @@ function Value.__init__(self, ...)
        self.template  = "cbi/value"
 
        self.maxlength  = nil
-       self.isnumber   = false
-       self.isinteger  = false
 end
 
 -- This validation is a bit more complex
@@ -600,7 +595,7 @@ function Value.validate(self, val)
                val = nil
        end
 
-       return luci.util.validate(val, self.isnumber, self.isinteger)
+       return val
 end
 
 
index 343c62725999a1827f3d6d9ae84f04294794bd56..11f77206bcefe149b18f550f8e3a359339d01da3 100644 (file)
@@ -276,20 +276,6 @@ function updfenv(f, extscope)
 end
 
 
--- Validates a variable
-function validate(value, cast_number, cast_int)
-       if cast_number or cast_int then
-               value = tonumber(value)
-       end
-       
-       if cast_int and value and not(value % 1 == 0) then
-               value = nil
-       end
-       
-       return value
-end
-
-
 -- Parse units from a string and return integer value
 function parse_units(ustr)
 
index 1ad067c6baf9c1597a0cbd9872b1c14577f1d7b2..a40888e7e83cabec9388f84e2b12e459144387f2 100644 (file)
@@ -1,8 +1,8 @@
 --[[
-LuCI - SGI-Module for Haserl
+LuCI - SGI-Module for Webuci
 
 Description:
-Server Gateway Interface for Haserl
+Server Gateway Interface for Webuci
 
 FileId:
 $Id: webuci.lua 2027 2008-05-07 21:16:35Z Cyrus $
index ff4170cb8a764285078e1f1f145e64d4756f2bc0..64355439b20023a66aa3c316f86fa5bc0aada33f 100644 (file)
@@ -158,10 +158,9 @@ function dispatch()
        local tpl = require("luci.template")
        tpl.viewns.translate   = function(...) return require("luci.i18n").translate(...) end
        tpl.viewns.controller  = luci.http.dispatcher()
-       tpl.viewns.uploadctrl  = luci.http.dispatcher_upload()
+       tpl.viewns.uploadctrl  = luci.http.dispatcher_upload() -- DEPRECATED
        tpl.viewns.media       = luci.config.main.mediaurlbase
        tpl.viewns.resource    = luci.config.main.resourcebase
-       tpl.viewns.uci         = require("luci.model.uci").config
        tpl.viewns.REQUEST_URI = luci.http.env.SCRIPT_NAME .. (luci.http.env.PATH_INFO or "")
        
 
index a6c57c6b095598b2c33e55df40e18d8878eafeeb..93d2e4787580d79cc4bf86575b34683a46a55705 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.index", package.seeall)
 
 function index()
index 397f2e4ca32b45714d02a282ffcb056c28841e70..3f8c4f303cf59624d94dd8ead55ae2b1f4291811 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.network", package.seeall)
 
 function index()
@@ -30,10 +43,4 @@ function index()
        page.target = cbi("admin_network/routes")
        page.title  = "Statische Routen"
        page.order  = 50
-       
-       if luci.fs.isfile("/etc/config/qos") then
-               local page  = node("admin", "network", "qos")
-               page.target = cbi("admin_network/qos")
-               page.title  = "Quality of Service"
-       end
 end
\ No newline at end of file
index b0024fb4ad862ef32912777706ff4bebf8e6b340..59defbbbdf15ce935aeccf9ccede2ac679551782 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.services", package.seeall)
 
 function index()
index afd6804f79a25e7e7431af5df017c339e664f32b..3a0f040747d5eac8b36db723ea33d74636da932c 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.status", package.seeall)
 
 function index()
index 81034fddfab0dd2027b7cf2926202586941c9d53..ef4e303fb5277582795829885b5c54824deb88a1 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.system", package.seeall)
 
 function index()
index fc70b9b410f339b81b140f6b736d90dcd799f00d..b69fef4cd2afb36db496a5551bcce93db49a440e 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.uci", package.seeall)
 
 function index()
index 84241b013e37109c52b16c3cffa4ad81110ad1a0..4bef0b7a520a9c8868796314e3da0661a1079a08 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.admin.wifi", package.seeall)
 
 function index()
index bdd8050bdd3b23c1f83a175f3ac2af5930a1a8d6..6d495eaaba82f1ae266c85ab66309a6613edd583 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 require("luci.config")
 m = Map("luci", translate("webui", "Oberfläche"), translate("a_i_luci1", 
  "Hier können Eigenschaften und die Funktionalität der Oberfläche angepasst werden."))
index e02238e39fc43fee83eaab144590cd75dd3445b3..321fd88ff4e254b60baad2aeff99420c52e720b3 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 require("luci.model.uci")
 require("luci.sys")
 
index a0c80f0f9cf004cea74a09a15c202a76483ddd50..3e06d6623697da9113b9ce6e822ac0da3417df3e 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("network", "Schnittstellen", [[An dieser Stelle können die einzelnen Schnittstellen 
 des Netzwerkes konfiguriert werden. Es können mehrere Schnittstellen zu einer Brücke zusammengefasst werden,
 indem diese durch Leerzeichen getrennt aufgezählt werden und ein entsprechender Haken im Feld Netzwerkbrücke
index 846bd75c2e9349cfe94c27ce98e1d7d53a9780ce..622240f1fc8d1a19e4cf97a27a953c1c19ebeac5 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("network", "Punkt-zu-Punkt Verbindungen", [[Punkt-zu-Punkt Verbindungen
 über PPPoE oder PPTP werden häufig dazu verwendet, um über DSL o.ä. Techniken eine
 Verbindung zum Internetgateway eines Internetzugangsanbieters aufzubauen.]])
diff --git a/modules/admin-core/luasrc/model/cbi/admin_network/qos.lua b/modules/admin-core/luasrc/model/cbi/admin_network/qos.lua
deleted file mode 100644 (file)
index d58130f..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
--- ToDo: Translate, Add descriptions and help texts
-m = Map("qos", "Quality of Service", [[Mit Hilfe von QoS kann einzelnen Rechnern oder Netzwerkdiensten
-eine höhere oder niedrigere Priorität zugewiesen werden.]])
-
-s = m:section(TypedSection, "interface", "Schnittstellen")
-s.addremove = true
-
-s:option(Flag, "enabled", "aktiviert")
-
-c = s:option(ListValue, "classgroup", "Klassifizierung")
-c:value("Default", "standard")
-c.default = "Default"
-
-s:option(Flag, "overhead", "Overheadberechnung")
-
-s:option(Value, "download", "Downlink", "kb/s")
-
-s:option(Value, "upload", "Uplink", "kb/s")
-
-s = m:section(TypedSection, "classify", "Klassifizierung")
-
-s.anonymous = true
-s.addremove = true
-
-t = s:option(ListValue, "target", "Klasse")
-t:value("Priority")
-t:value("Express")
-t:value("Normal")
-t:value("Bulk")
-t.default = "Normal"
-
-s:option(Value, "srchost", "Quelladresse", "Quellhost / Quellnetz").optional = true
-s:option(Value, "dsthost", "Zieladresse", "Zielhost / Zielnetz").optional = true
-s:option(Value, "layer7", "Layer 7").optional = true
-
-p2p = s:option(ListValue, "ipp2p", "P2P")
-p2p:value("")
-p2p:value("all", "Alle")
-p2p:value("bit", "Bittorrent")
-p2p:value("dc", "DirectConnect")
-p2p:value("edk", "eDonkey")
-p2p:value("gnu", "Gnutella")
-p2p:value("kazaa", "Kazaa")
-p2p.optional = true
-
-p = s:option(ListValue, "proto", "Protokoll")
-p:value("")
-p:value("tcp", "TCP")
-p:value("udp", "UDP")
-p:value("icmp", "ICMP")
-p.optional = true
-
-s:option(Value, "ports", "Port").optional = true
-s:option(Value, "portrange", "Portbereich").optional = true
-
-return m
\ No newline at end of file
index 7882e9afabfacd4edc52b1b104bdc24515d240f0..da115bdfeed7bccd4554efeda443081e5694b6ad 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("network", "Statische Routen", [[Statische Routen geben an,
 über welche Schnittstelle und welches Gateway ein bestimmter Host
 oder ein bestimmtes Netzwerk erreicht werden kann.]])
index 08371ea3f1d908963d4d1ac1591eb882ce2fb807..487c0371e73f1ecd529e07996dea04e78036ccb9 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Autodetect things, maybe use MultiValue instead, Translate, Add descriptions
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("network", "VLAN", [[Die Netzwerkschnittstellen am Router
 können zu verschienden VLANs zusammengefasst werden, in denen Geräte miteinander direkt
 kommunizieren können. VLANs werden auch häufig dazu genutzt, um Netzwerke voneiander zu trennen.
index 86716ff9f3040d3112cb75354dbc1c6ada6bd073..ab18035ef343aee1d66c7d1a3aac984e64542f56 100644 (file)
@@ -1,29 +1,42 @@
-m = Map("dhcp", "Dnsmasq", "Dnsmasq ist ein kombinierter DHCP-Server und DNS-Forwarder für NAT-Firewalls.")
+--[[
+LuCI - Lua Configuration Interface
 
-s = m:section(TypedSection, "dnsmasq", "Einstellungen")
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("dhcp", "Dnsmasq")
+
+s = m:section(TypedSection, "dnsmasq", translate("settings", "Einstellungen"))
 s.anonymous = true
 
-s:option(Flag, "domainneeded", "Anfragen nur mit Domain", "Anfragen ohne Domainnamen nicht weiterleiten")
-s:option(Flag, "authoritative", "Authoritativ", "Dies ist der einzige DHCP im lokalen Netz")
-s:option(Flag, "boguspriv", "Private Anfragen filtern", "Reverse DNS-Anfragen für lokalen Netze nicht weiterleiten")
-s:option(Flag, "filterwin2k", "Windowsanfragen filtern", "nutzlose DNS-Anfragen aktueller Windowssysteme filtern")
-s:option(Flag, "localise_queries", "Lokalisiere Anfragen", "Gibt die Adresse eines Hostnamen entsprechend seines Subnetzes zurück")
-s:option(Value, "local", "Lokale Server")
-s:option(Value, "domain", "Lokale Domain")
-s:option(Flag, "expandhosts", "Erweitere Hosts", "Fügt Domainnamen zu einfachen Hosteinträgen in der Resolvdatei hinzu")
-s:option(Flag, "nonegcache", "Unbekannte nicht cachen", "Negative DNS-Antworten nicht zwischenspeichern")
-s:option(Flag, "readethers", "Verwende /etc/ethers", "Lese Informationen aus /etc/ethers um den DHCP-Server zu konfigurieren")
-s:option(Value, "leasefile", "Leasedatei", "Speicherort für vergebenen DHCP-Adressen")
-s:option(Value, "resolvfile", "Resolvdatei", "Lokale DNS-Datei")
-s:option(Flag, "nohosts", "Ignoriere /etc/hosts").optional = true
-s:option(Flag, "strictorder", "Strikte Reihenfolge", "DNS-Server werden strikt der Reihenfolge in der Resolvdatei nach abgefragt").optional = true
-s:option(Flag, "logqueries", "Schreibe Abfragelog").optional = true
-s:option(Flag, "noresolv", "Ignoriere Resolvdatei").optional = true
-s:option(Value, "dnsforwardmax", "gleichzeitige Abfragen").optional = true
-s:option(Value, "port", "DNS-Port").optional = true
-s:option(Value, "ednspacket_max", "max. EDNS.0 Paketgröße").optional = true
-s:option(Value, "dhcpleasemax", "max. DHCP-Leases").optional = true
-s:option(Value, "addnhosts", "Zusätzliche Hostdatei").optional = true
-s:option(Value, "queryport", "Abfrageport").optional = true
+s:option(Flag, "domainneeded")
+s:option(Flag, "authoritative")
+s:option(Flag, "boguspriv")
+s:option(Flag, "filterwin2k")
+s:option(Flag, "localise_queries")
+s:option(Value, "local")
+s:option(Value, "domain")
+s:option(Flag, "expandhosts")
+s:option(Flag, "nonegcache")
+s:option(Flag, "readethers")
+s:option(Value, "leasefile")
+s:option(Value, "resolvfile")
+s:option(Flag, "nohosts").optional = true
+s:option(Flag, "strictorder").optional = true
+s:option(Flag, "logqueries").optional = true
+s:option(Flag, "noresolv").optional = true
+s:option(Value, "dnsforwardmax").optional = true
+s:option(Value, "port").optional = true
+s:option(Value, "ednspacket_max").optional = true
+s:option(Value, "dhcpleasemax").optional = true
+s:option(Value, "addnhosts").optional = true
+s:option(Value, "queryport").optional = true
 
 return m
\ No newline at end of file
index 558cc9c7a7b360d1143649aec573581e1137d91d..991f8852a43a18e932bba33e52b189c1405c4f74 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("dropbear", "Dropbear SSHd", translate("a_srv_dropbear1", [[Der SSH-Server ermöglicht Shell-Zugriff
 über das Netzwerk und bietet einen integrierten SCP-Dienst.]]))
 
index 083893d48dd726771dab90d06422e07c868b9d38..32c1bab26c3ffbb4b40b7d83c9f94d4fd2e0b52f 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("httpd", "Busybox HTTPd", translate("a_srv_http1", "Ein kleiner Webserver, der für die Bereitstellung von LuCI genutzt werden kann."))
 
 s = m:section(TypedSection, "httpd", "")
index f8df2351833547966102b3ec3a11852890340f0d..8370bee52335d478a27b72ceeea3229d6205be66 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("fstab", translate("a_s_fstab", "Einhängepunkte"))
 
 mount = m:section(TypedSection, "mount", translate("a_s_fstab_mountpoints", "Einhängepunkte"), translate("a_s_fstab_mountpoints1", [[Einhängepunkte bestimmen, an welcher Stelle des Dateisystems
index b0b79982496a275453278cfd244c2979ab535d4f..ad678f707acdc19cd6382ac8959235f67217f71a 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("system", translate("hostname", "Hostname"), translate("a_s_hostname1", [[Definiert den Hostnamen des Routers.
 Der Hostname ist eine im Netzwerk eindeutige Kennung, die dieses Gerät identifiziert.]]))
 
index 1e5be667fc49316238121d84f7450eef47c8219d..15832220471f1253392cdc5808684907a0502393 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("wireless", translate("devices", "Geräte"), translate("a_w_devices1", 
        "An dieser Stelle können eingebaute WLAN-Geräte konfiguriert werden."))
 
index 4220840a042dfa02dfbe78caa17f62c3e8d117f2..19aa0e1c4ffedbbdbc28635cbff1373a273fcb17 100644 (file)
@@ -1,4 +1,16 @@
--- ToDo: Translate, Add descriptions and help texts
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("wireless", translate("networks", "Netze"), translate("a_w_networks1", [[Pro WLAN-Gerät können mehrere Netze bereitgestellt werden.
 Es sollte beachtet werden, dass es hardware- / treiberspezifische Einschränkungen gibt.
 So kann pro WLAN-Gerät in der Regel entweder 1 Ad-Hoc-Zugang ODER bis zu 3 Access-Point und 1 Client-Zugang
index 636b9fcd376867a1dc0461074619a9bf48005a92..a3bafc0eb2c81262e4e36c8b357b50023f08f982 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.freifunk.freifunk", package.seeall)
 
 function index()
index f7cbbf0639fe0e4c1474fe5342b86b2491c84b37..4c24c5732b82fc4ee152b0f72d8e021e9914c008 100644 (file)
@@ -1,3 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 module("luci.controller.freifunk.luciinfo", package.seeall)
 
 function index()
index 838f401a9763885f5dc80460252f2c3c93c63ecd..0998cb924d9d49790aa76451e833dded1cdad3a6 100644 (file)
@@ -1,4 +1,16 @@
--- Todo: Translate
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("freifunk", translate("contact", "Kontakt"), translate("contact1", [[Diese Daten sind
 auf der öffentlichen Kontaktseite sichtbar. Bitte gib an, wie man dich am besten kontaktieren kann.
 Diese Informationen sollten nach der Picopeering Vereinbarung mindestens deine E-Mail-Adresse enthalten.
index fe9e285b49a3b543d9680a9db42375dd129b03f2..54d984988e322d1854658f059cef2ab65bd3c4f0 100644 (file)
@@ -1,4 +1,16 @@
--- Todo: Translate
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
 m = Map("freifunk", "Freifunk")
 
 c = m:section(NamedSection, "community", "public", "Gemeinschaft", [[Dies sind die Grundeinstellungen