luci-lib-nixio: always build without TLS support 5929/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 10 Aug 2022 14:16:52 +0000 (11:16 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 10 Aug 2022 19:52:35 +0000 (16:52 -0300)
The build system fails to set up the chosen TLS provider and always
builds the package without TLS.

While this could be easily fixed, the package would fail to build with
axTLS and cyaSSL without further intervention.

The version of axTLS included with the source is outdated, as is the API
used with cyaSSL, now wolfSSL.

OpenSSL support could be enabled, but the TLS code limits connections to
TLS 1.0, deprecated by RFC 8996: "TLS 1.0 MUST NOT be used".

Remove the provider configuration from build options, and always build
the library without TLS.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/luci-lib-nixio/Makefile

index 4e501b89cec2e250757dcba8bb5ff14a06d37643..91715e41d33332a2038b7d56ee415a5cec699a51 100644 (file)
@@ -7,48 +7,10 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=NIXIO POSIX library
-LUCI_DEPENDS:=+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl +liblua
+LUCI_DEPENDS:=+liblua
 
 PKG_LICENSE:=Apache-2.0
 
-define Package/luci-lib-nixio/config
-       choice
-               prompt "TLS Provider"
-               default PACKAGE_luci-lib-nixio_notls
-
-               config PACKAGE_luci-lib-nixio_notls
-                       bool "Disabled"
-
-               config PACKAGE_luci-lib-nixio_axtls
-                       bool "Builtin (axTLS)"
-
-               config PACKAGE_luci-lib-nixio_cyassl
-                       bool "CyaSSL"
-                       select PACKAGE_libcyassl
-
-               config PACKAGE_luci-lib-nixio_openssl
-                       bool "OpenSSL"
-                       select PACKAGE_libopenssl
-       endchoice
-endef
-
-NIXIO_TLS:=
-
-ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_axtls),)
-  NIXIO_TLS:=axtls
-endif
-
-ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_openssl),)
-  NIXIO_TLS:=openssl
-endif
-
-ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
-  NIXIO_TLS:=cyassl
-  LUCI_CFLAGS+=-I$(STAGING_DIR)/usr/include/cyassl
-endif
-
-MAKE_VARS += NIXIO_TLS="$(NIXIO_TLS)"
-
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature