build: fix clean targets in Makefiles (#667)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 5 Feb 2014 13:35:34 +0000 (13:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 5 Feb 2014 13:35:34 +0000 (13:35 +0000)
Makefile
contrib/uci/Makefile
libs/web/Makefile

index 7dc9fa1e8ebe3d92a0e4d112687dc7e8b3554fd4..362eed69ffb499a5d36119f8d1c2dd654105972b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,7 @@ i18nbuild:
 clean:
        rm -f .running-sdk
        rm -rf docs
-       make -C libs/lmo host-clean
+       make -C libs/web host-clean
        for i in $(MODULES); do make -C$$i clean; done
 
 
index b0ea8c0b6094e48b323c57b4dcab3b0c283a7dbb..d04c5a146a050c5aeed5cf0600efb980b01a8ab6 100644 (file)
@@ -39,4 +39,5 @@ compile: $(UCI_DIR)/.prepared
 compile-all: compile
 
 clean:
+       rm -rf $(UCI_PATCHDIR)/series
        rm -rf $(UCI_DIR) $(UCI_FILE)
index 1d28a3a4ce8b1492e6681a59fce7d36161949f3e..ad16ec737665f405b3482ddce8cbb723fbdc52c4 100644 (file)
@@ -41,4 +41,5 @@ host-install: host-compile
        cp src/$(TPL_PO2LMO) ../../build/$(TPL_PO2LMO)
 
 host-clean:
+       rm -f src/$(TPL_PO2LMO)
        rm -f ../../build/$(TPL_PO2LMO)