luci-proto-hnet: move hnet to own package
authorFlorian Eckert <fe@dev.tdt.de>
Thu, 15 Mar 2018 07:54:10 +0000 (08:54 +0100)
committerYousong Zhou <yszhou4tech@gmail.com>
Sun, 30 Sep 2018 09:49:09 +0000 (17:49 +0800)
This is a special proto which should go into a separate package.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
protocols/luci-proto-hnet/Makefile [new file with mode: 0644]
protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua [new file with mode: 0644]
protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua [new file with mode: 0644]
protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua [deleted file]
protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua [deleted file]

diff --git a/protocols/luci-proto-hnet/Makefile b/protocols/luci-proto-hnet/Makefile
new file mode 100644 (file)
index 0000000..10beb03
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2018 Florian Eckert <fe@dev.tdt.de>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for hnet
+LUCI_DEPENDS:=
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua
new file mode 100644 (file)
index 0000000..2ed34fa
--- /dev/null
@@ -0,0 +1,37 @@
+-- Copyright 2013 Steven Barth <steven@midlink.org>
+-- Licensed to the public under the Apache License 2.0.
+
+local map, section, net = ...
+
+local mode = section:taboption("general", ListValue, "mode", translate("Category"))
+mode:value("auto", translate("Automatic"))
+mode:value("external", translate("External"))
+mode:value("internal", translate("Internal"))
+mode:value("leaf", translate("Leaf"))
+mode:value("guest", translate("Guest"))
+mode:value("adhoc", translate("Ad-Hoc"))
+mode:value("hybrid", translate("Hybrid"))
+mode.default = "auto"
+
+
+
+local plen = section:taboption("advanced", Value, "ip6assign", translate("IPv6 assignment length"),
+       translate("Assign a part of given length of every public IPv6-prefix to this interface"))
+plen.datatype = "max(128)"
+plen.default = "64"
+
+section:taboption("advanced", Value, "link_id", translate("IPv6 assignment hint"),
+       translate("Assign prefix parts using this hexadecimal subprefix ID for this interface."))
+
+plen = section:taboption("advanced", Value, "ip4assign", translate("IPv4 assignment length"))
+plen.datatype = "max(32)"
+plen.default = "24"
+
+local o = section:taboption("advanced", Value, "dnsname", translate("DNS-Label / FQDN"))
+o.default = map.name
+
+luci.tools.proto.opt_macaddr(section, ifc, translate("Override MAC address"))
+
+o = section:taboption("advanced", Value, "mtu", translate("Override MTU"))
+o.placeholder = "1500"
+o.datatype    = "max(9200)"
diff --git a/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua
new file mode 100644 (file)
index 0000000..f525061
--- /dev/null
@@ -0,0 +1,16 @@
+-- Copyright 2014 Steven Barth <steven@midlink.org>
+-- Licensed to the public under the Apache License 2.0.
+
+local proto = luci.model.network:register_protocol("hnet")
+
+function proto.get_i18n(self)
+       return luci.i18n.translate("Automatic Homenet (HNCP)")
+end
+
+function proto.is_installed(self)
+       return nixio.fs.access("/lib/netifd/proto/hnet.sh")
+end
+
+function proto.opkg_package(self)
+       return "hnet-full"
+end
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua
deleted file mode 100644 (file)
index 2ed34fa..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
--- Copyright 2013 Steven Barth <steven@midlink.org>
--- Licensed to the public under the Apache License 2.0.
-
-local map, section, net = ...
-
-local mode = section:taboption("general", ListValue, "mode", translate("Category"))
-mode:value("auto", translate("Automatic"))
-mode:value("external", translate("External"))
-mode:value("internal", translate("Internal"))
-mode:value("leaf", translate("Leaf"))
-mode:value("guest", translate("Guest"))
-mode:value("adhoc", translate("Ad-Hoc"))
-mode:value("hybrid", translate("Hybrid"))
-mode.default = "auto"
-
-
-
-local plen = section:taboption("advanced", Value, "ip6assign", translate("IPv6 assignment length"),
-       translate("Assign a part of given length of every public IPv6-prefix to this interface"))
-plen.datatype = "max(128)"
-plen.default = "64"
-
-section:taboption("advanced", Value, "link_id", translate("IPv6 assignment hint"),
-       translate("Assign prefix parts using this hexadecimal subprefix ID for this interface."))
-
-plen = section:taboption("advanced", Value, "ip4assign", translate("IPv4 assignment length"))
-plen.datatype = "max(32)"
-plen.default = "24"
-
-local o = section:taboption("advanced", Value, "dnsname", translate("DNS-Label / FQDN"))
-o.default = map.name
-
-luci.tools.proto.opt_macaddr(section, ifc, translate("Override MAC address"))
-
-o = section:taboption("advanced", Value, "mtu", translate("Override MTU"))
-o.placeholder = "1500"
-o.datatype    = "max(9200)"
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua b/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
deleted file mode 100644 (file)
index f525061..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
--- Copyright 2014 Steven Barth <steven@midlink.org>
--- Licensed to the public under the Apache License 2.0.
-
-local proto = luci.model.network:register_protocol("hnet")
-
-function proto.get_i18n(self)
-       return luci.i18n.translate("Automatic Homenet (HNCP)")
-end
-
-function proto.is_installed(self)
-       return nixio.fs.access("/lib/netifd/proto/hnet.sh")
-end
-
-function proto.opkg_package(self)
-       return "hnet-full"
-end