luci-app-adblock-fast: bugfix: working re-download 6621/head
authorStan Grishin <stangri@melmac.ca>
Thu, 5 Oct 2023 14:55:29 +0000 (14:55 +0000)
committerStan Grishin <stangri@melmac.ca>
Thu, 5 Oct 2023 14:55:48 +0000 (14:55 +0000)
* bugfix: add missing dl command to RPCD script
* improve output of error messages/link to README

Signed-off-by: Stan Grishin <stangri@melmac.ca>
applications/luci-app-adblock-fast/Makefile
applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js
applications/luci-app-adblock-fast/po/templates/adblock-fast.pot
applications/luci-app-adblock-fast/root/usr/libexec/rpcd/luci.adblock-fast

index b9aa17849b7c3b10b8fa7e75861df857e09fa5f4..a1666f199ebe453a5d349c7e5c680044780d37eb 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.0.0-4
+PKG_VERSION:=1.0.0-6
 
 LUCI_TITLE:=AdBlock-Fast Web UI
 LUCI_DESCRIPTION:=Provides Web UI for adblock-fast service.
index ae41968944b11548dc0d8c7cdb46ed764f607cd7..89dcb8846e4ff9f5c546acc3715cffc6d6da52e8 100644 (file)
@@ -288,11 +288,11 @@ var status = baseclass.extend({
                                        var text = "";
                                        reply.status.errors.forEach((element) => {
                                                text +=
-                                                       errorTable[element.id].format(element.extra || " ") + "<br />";
+                                                       errorTable[element.id].format(element.extra || " ") + "!<br />";
                                        });
-                                       text += _("Errors encountered, please check the %sREADME%s!").format(
+                                       text += _("Errors encountered, please check the %sREADME%s").format(
                                                '<a href="' + pkg.URL + '" target="_blank">',
-                                               "</a><br />"
+                                               "</a>!<br />"
                                        );
                                        var errorsText = E("div", {}, text);
                                        var errorsField = E("div", { class: "cbi-value-field" }, errorsText);
index 630353a0beb7c3d6faf27b6832251377eceee825..58d4800b179d779ae863fec7b1ece8cd959f5145 100644 (file)
@@ -200,7 +200,7 @@ msgid "Error"
 msgstr ""
 
 #: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:293
-msgid "Errors encountered, please check the %sREADME%s!"
+msgid "Errors encountered, please check the %sREADME%s"
 msgstr ""
 
 #: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:117
index b85a93f2e68168f7c4344cc97cae3f502ba4a289..be4d0a320bfaee4e9d40523659fa58e5a9b253b9 100755 (executable)
@@ -10,6 +10,7 @@
 # ubus -S call luci.adblock-fast getInitStatus '{"name": "adblock-fast" }'
 # ubus -S call luci.adblock-fast getPlatformSupport '{"name": "adblock-fast" }'
 # ubus -S call luci.adblock-fast setInitAction '{"name": "adblock-fast", "action": "start" }'
+# ubus -S call luci.adblock-fast setInitAction '{"name": "adblock-fast", "action": "dl" }'
 # ubus -S call luci.adblock-fast setInitAction '{"name": "adblock-fast", "action": "stop" }'
 
 . /lib/functions.sh
@@ -134,7 +135,7 @@ set_init_action() {
                        cmd="uci -q set ${name}.config.enabled=1 && uci commit $name";;
                disable)
                        cmd="uci -q set ${name}.config.enabled=0 && uci commit $name";;
-               start|stop|reload|restart)
+               start|stop|reload|restart|dl)
                        cmd="/etc/init.d/${name} ${action}";;
        esac
        if [ -n "$cmd" ] && eval "${cmd}" 1>/dev/null 2>&1; then