lucihttp: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Fri, 11 Jun 2021 06:28:31 +0000 (08:28 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 11 Jun 2021 06:32:03 +0000 (08:32 +0200)
Fixes compilation under 32bit systems by using the proper printf format
specifier for size_t values.

Also fixes compilation with Ninja by appending instead of
overwriting CMAKE_OPTIONS.

Fixes: #5116
Suggested-by: Rosen Penev <rosenp@gmail.com>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
contrib/package/lucihttp/Makefile

index a1b740deedf6007757c61ae5e2163150dd11f240..e0deae10f3d81e907051f2ba718a4817718b063e 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/lucihttp.git
-PKG_SOURCE_DATE:=2019-07-05
-PKG_SOURCE_VERSION:=a34a17d501c0e23f0a91dd9d3e87697347c861ba
-PKG_MIRROR_HASH:=f08b526515b4a654e5529457da9d0676696170846288c55863dba087417a0483
+PKG_SOURCE_DATE:=2021-06-11
+PKG_SOURCE_VERSION:=3dc89af443410c9eae7a0ff091bd7fb4c5d48f41
+PKG_MIRROR_HASH:=6024a34c514a7231bcc36486abfb3e43e6c17490ac8d838f202a43ce259cda03
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=ISC
@@ -35,7 +35,7 @@ endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
        -DLUAPATH=/usr/lib/lua \
        -DBUILD_LUA=$(if $(CONFIG_PACKAGE_liblucihttp-lua),ON,OFF) \
        -DBUILD_TESTS=OFF