lua: include /opt/local/lib and /opt/local/include in the search path on mac os x
authorFelix Fietkau <nbd@openwrt.org>
Thu, 4 Oct 2012 14:04:46 +0000 (16:04 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 4 Oct 2012 14:04:46 +0000 (16:04 +0200)
lua/CMakeLists.txt

index 63c6a40cc27408618e8fbf53e56f642a7096aa35..e4295d7d452b1c4b129587288f335d28bf2faa0f 100644 (file)
@@ -18,6 +18,11 @@ ENDIF()
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -I.. ${LUA_CFLAGS})
 LINK_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
+IF(APPLE)
+  INCLUDE_DIRECTORIES(/opt/local/include)
+  LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
 IF(APPLE)
        SET(CMAKE_SHARED_MODULE_CREATE_C_FLAGS "${CMAKE_SHARED_MODULE_CREATE_C_FLAGS} -undefined dynamic_lookup")
 ENDIF(APPLE)