netifd: update to Git HEAD (2024-09-03)
[openwrt/staging/stintel.git] / include / autotools.mk
index cba36ccd9fa2b83a9a3b64efaad81c0575fe828b..7fc6f371750160535da459bca9d3b1c3c6a797b1 100644 (file)
@@ -26,6 +26,8 @@ AM_TOOL_PATHS:= \
        AUTOPOINT=true \
        GTKDOCIZE=true
 
+AM_TOOL_PATHS_FAKE:=$(subst = ,=,$(patsubst "%,"$(TRUE)",$(subst =,= ",$(AM_TOOL_PATHS))))
+
 # 1: build dir
 # 2: remove files
 # 3: automake paths
@@ -42,7 +44,7 @@ define autoreconf
                                touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
                                $(AM_TOOL_PATHS) \
                                        LIBTOOLIZE='$(STAGING_DIR_HOST)/bin/libtoolize --install' \
-                                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i \
                                        $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        $(patsubst %,-I %,$(5)) \
@@ -124,13 +126,6 @@ ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
   Hooks/Configure/Post += set_libtool_abiver
 endif
 
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
- ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
-  Hooks/Configure/Pre += autoreconf_target
- endif
-endif
-
 ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
     Hooks/Configure/Pre += autoreconf_target
@@ -166,12 +161,6 @@ ifneq ($(filter libtool,$(HOST_FIXUP)),)
  endif
 endif
 
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
-  Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
 ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
     Hooks/HostConfigure/Pre += autoreconf_host