upgrade 3.13 targets to 3.13.7
[openwrt/openwrt.git] / include / download.mk
index 372db03194a5e41739031b1e2bc395e062f9658f..1c3f23e94ba552aa2297ac3c1f5165152c98bf3c 100644 (file)
@@ -88,7 +88,7 @@ define DownloadMethod/git
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
                git clone $(URL) $(SUBDIR) --recursive && \
-               (cd $(SUBDIR) && git checkout $(VERSION)) && \
+               (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \