ixp4xx: replace magic number with macros in avila/ixdp425/miccpt PCI routing setup
[openwrt/openwrt.git] / include / host.mk
index 8092e8db77ac74e1f07c2c1ab1e15b7f1a9a30b4..b44c1bf1ac6f3a9a1af9f865e48613a0d87d5ec4 100644 (file)
@@ -36,7 +36,7 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
                        GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
@@ -59,6 +59,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo 'XARGS:=xargs' >> $@; \
                fi; \
+               PATCH=`which gpatch 2>/dev/null`; \
+               [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
+               echo "PATCH:=$$PATCH" >> $@; \
+               PYTHON=`which python2.7 2>/dev/null`; \
+               [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
+               echo "PYTHON:=$$PYTHON" >> $@; \
        )
 
 endif