cake: bump to 20180504 bake
[openwrt/staging/mkresin.git] / include / image-commands.mk
index 0f9ac0836cedb5b6d5ac9b327fba1df65ebc72ae..a8486553998e882ec46ce1434003fece3ce6118c 100644 (file)
@@ -77,16 +77,17 @@ define Build/append-squashfs-fakeroot-be
        cat $@.fakesquashfs >> $@
 endef
 
-# append a fake/empty rootfs uImage header, to fool the bootloaders
-# rootfs integrity check
-define Build/append-uImage-fakeroot-hdr
-       rm -f $@.fakeroot
+# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
+# for example
+define Build/append-uImage-fakehdr
+       touch $@.fakehdr
        $(STAGING_DIR_HOST)/bin/mkimage \
-               -A $(LINUX_KARCH) -O linux -T filesystem -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
+               -A $(LINUX_KARCH) -O linux -T $(1) -C none \
+               -n '$(VERSION_DIST) fake $(1)' \
+               -d $@.fakehdr \
                -s \
-               $@.fakeroot
-       cat $@.fakeroot >> $@
+               $@.fakehdr
+       cat $@.fakehdr >> $@
 endef
 
 define Build/tplink-safeloader