ramips: add encrypted SGE factory image for D-Link devices
[openwrt/openwrt.git] / include / image-commands.mk
index 77a35f3eec00703ad3b61a38ff24218157d68ff6..d07c8827619fc2cb3deafa9970cf9099f23492d3 100644 (file)
@@ -226,6 +226,11 @@ define Build/copy-file
        cat "$(1)" > "$@"
 endef
 
+define Build/dlink-sge-image
+       $(STAGING_DIR_HOST)/bin/dlink-sge-image $(1) $@ $@.enc
+       mv $@.enc $@
+endef
+
 define Build/edimax-header
        $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
        @mv $@.new $@