use --binary option of md5sum to improve compatibility with other platforms (#5192)
[openwrt/staging/mkresin.git] / include / image.mk
index 686c5a551e623f8d7a95d292cf387ec99177e07d..0b2d3e358963ec9aaa818713f807cd51178025df 100644 (file)
@@ -23,7 +23,7 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
-ifneq ($(CONFIG_LINUX_2_6_29)$(CONFIG_LINUX_2_6_30),)
+ifneq ($(CONFIG_LINUX_2_6_30),)
 USE_SQUASHFS4 := y
 endif
 
@@ -92,7 +92,7 @@ endif
 define Image/Checksum
        ( cd ${BIN_DIR} ; \
                $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
-               md5sum > md5sums \
+               md5sum --binary > md5sums \
        )
 endef