fix grub segfaults on hosts where gcc is built with stack smashing protection
[openwrt/staging/mkresin.git] / include / kernel-build.mk
index 03b4769f4bb1ba095084358f8dbdfa75dbc1bce1..6d9c9d978d17ebdf34817919c80043c40ab6bc5e 100644 (file)
@@ -33,8 +33,8 @@ ifeq ($(DUMP),1)
 else
   all: compile
 endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
+include $(INCLUDE_DIR)/kernel-version.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/kernel.mk
 
@@ -56,6 +56,9 @@ KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"
 endif
+ifneq (,$(findstring rdc,$(BOARD)))
+  KERNELNAME="bzImage"
+endif
 ifneq (,$(findstring ppc,$(BOARD)))
   KERNELNAME="uImage"
 endif
@@ -63,7 +66,7 @@ endif
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches 
+       [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches 
        [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
 endef
 define Kernel/Prepare