some cleanups in the metadata.pl script; allow target profiles to add overrides for...
[openwrt/openwrt.git] / include / kernel-build.mk
index 50c9fced0f91b129e9edf933d4769838b3d1d76e..b2837d1df34c1f058449f9125eae8235b8daa30d 100644 (file)
@@ -13,7 +13,7 @@ include $(INCLUDE_DIR)/prereq.mk
 
 LINUX_CONFIG ?= ./config/default
 
--include $(GENERIC_PLATFORM_DIR)/config-template
+-include $(TOPDIR)/target/linux/generic-$(KERNEL)/config-template
 -include $(LINUX_CONFIG)
 
 ifneq ($(CONFIG_ATM),)
@@ -37,6 +37,9 @@ FEATURES:=$(sort $(FEATURES))
 
 # For target profile selection - the default set
 DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd kmod-ipt-nathelper
+ifneq ($(KERNEL),2.4)
+  DEFAULT_PACKAGES+=udevtrigger hotplug2
+endif
 
 ifeq ($(DUMP),1)
   all: dumpinfo
@@ -136,6 +139,7 @@ define Kernel/CompileImage/Default
        $(call Kernel/SetInitramfs)
        $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
+       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux.elf
 endef
 define Kernel/CompileImage
        $(call Kernel/CompileImage/Default)
@@ -216,6 +220,7 @@ confname=$(subst .,_,$(subst -,_,$(1)))
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
+  $(eval $(call shexport,Profile/$(1)/Config))
   $(eval $(call shexport,Profile/$(1)/Description))
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
@@ -224,6 +229,9 @@ define Profile
        if [ -f ./config/profile-$(1) ]; then \
                echo "Target-Profile-Kconfig: yes"; \
        fi; \
+       echo "Target-Profile-Config: "; \
+       getvar "$(call shvar,Profile/$(1)/Config)"; \
+       echo "@@"; \
        echo "Target-Profile-Description:"; \
        getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \