fix the image builder
[openwrt/staging/mkresin.git] / include / kernel-defaults.mk
index 4b25f544a2656872c8e96f69f125fd1340c63f90..69ff8fa6f0fe8481c95151a38419759e4ec29699 100644 (file)
@@ -5,22 +5,6 @@
 # See /LICENSE for more information.
 #
 
-# default device type
-DEVICE_TYPE?=router
-
-# Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd mtd
-# For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
-
-# Additional packages for Linux 2.6
-ifneq ($(KERNEL),2.4)
-  DEFAULT_PACKAGES += udevtrigger hotplug2
-endif
-
-# Add device specific packages
-DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
-
 KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"