netifd: update to Git HEAD (2024-09-03)
[openwrt/staging/stintel.git] / include / meson.mk
index 65716746fe1eec4aaf3ac03c8069c960eb4c3476..2a20c2bd6bd04ef7164d2564591ced8e3fcd7bc0 100644 (file)
@@ -100,6 +100,7 @@ define Host/Configure/Meson
        $(call Meson, \
                setup \
                --native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
+               -Ddefault_library=static \
                $(MESON_HOST_ARGS) \
                $(MESON_HOST_BUILD_DIR) \
                $(MESON_HOST_BUILD_DIR)/.., \
@@ -126,6 +127,7 @@ define Build/Configure/Meson
                --buildtype plain \
                --native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
                --cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
+               -Ddefault_library=both \
                $(MESON_ARGS) \
                $(MESON_BUILD_DIR) \
                $(MESON_BUILD_DIR)/.., \