tools/squashfs: rename to squashfs3-lzma
[openwrt/openwrt.git] / include / prereq-build.mk
index 7959890eb52e9174319e2307f8f644bc881a040b..8fae92ab977087f38f9bac051d57e49c8bc1163b 100644 (file)
@@ -204,6 +204,20 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
        /bin/which which, \
        which which))
 
+ifeq ($(HOST_OS),Linux)
+  $(eval $(call RequireCHeader,argp.h, \
+       Missing argp.h Please install the argp-standalone package if musl libc))
+
+  $(eval $(call RequireCHeader,fts.h, \
+       Missing fts.h Please install the musl-fts-dev package if musl libc))
+
+  $(eval $(call RequireCHeader,obstack.h, \
+       Missing obstack.h Please install the musl-obstack-dev package if musl libc))
+
+  $(eval $(call RequireCHeader,libintl.h, \
+       Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
+
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)
        $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<