prereq-build: revert "fix `which` detection on Fedora"
[openwrt/openwrt.git] / include / prereq-build.mk
index 8fbf6f22c4e5352ef61164fdb35ec66b970c73cd..9242407b1896321b376701a8f8928157c95cfcd0 100644 (file)
@@ -157,6 +157,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+       python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
@@ -164,12 +165,17 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
        python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+       python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
 
+$(eval $(call TestHostCommand,python3-distutils, \
+       Please install the Python3 distutils module, \
+       $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
+
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))