prereq-build: do not replace binaries with symlinks
[openwrt/openwrt.git] / include / prereq.mk
index 45c84e984c6f2942ac34b7b2a5153bcfcf8969ac..ada11a87019920a759b85eeee120ec7f6d2df34a 100644 (file)
@@ -110,6 +110,10 @@ define SetupHostCommand
                                        *" -> $$$$$$$$bin"*) \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
+                                       "-"*) \
+                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
+                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
+                                               ;; \
                                esac; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
                                exit 0; \