package/base-files: fix typo in r20874 (thanks to rhk for spotting it)
[openwrt/openwrt.git] / include / target.mk
index 61ff2d21aa75eb197c9cd7431c47e0bfa50cfd09..5eb8547cc2ec5c8f0404490887e9f0dc2813d899 100644 (file)
@@ -148,7 +148,9 @@ ifeq ($(DUMP),1)
       FEATURES += pcie
     endif
     ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
-      FEATURES += usb
+      ifneq ($(CONFIG_USB_ARCH_HAS_HCD)$(CONFIG_USB_EHCI_HCD),)
+        FEATURES += usb
+      endif
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia