[packages] qt4: disable on brcm-2.4, it fails due to missing tslib support
[openwrt/svn-archive/archive.git] / lang / kid / Makefile
index 936f3417d8cc264b5113c1693d0acda1d9800289..252c6f10a5c86f494a5de01c7021b1942e9c3106 100644 (file)
@@ -1,3 +1,10 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kid
@@ -7,29 +14,37 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
 PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-kid
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  DEPENDS:=+python
+  TITLE:=XML-based Templating
+  URL:=http://www.kid-templating.org/
+endef
 
-define Package/kid
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Kid
- DEPENDS:=+python
- DESCRIPTION:=\
-  Kid is a simple template language for XML based vocabularies written in Python.
- URL=http://www.kid-templating.org/
+define Package/python-kid/description
+ Kid is a simple template language for XML based vocabularies written in 
+ Python.
 endef
 
-define Build/Compile
-       $(call Build/Compile/PyMod,,install)
+define PyPackage/python-kid/filespec
++|$(PYTHON_PKG_DIR)/kid
+-|$(PYTHON_PKG_DIR)/kid/test
 endef
 
-define Package/kid/install
-       $(CP) -R $(PKG_INSTALL_DIR)/* $(1)
+define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
+               install --prefix="$(PKG_INSTALL_DIR)/usr", \
+       )
 endef
 
-$(eval $(call BuildPackage,kid))
+$(eval $(call PyPackage,python-kid))
+$(eval $(call BuildPackage,python-kid))