Add libxcb.
[openwrt/svn-archive/archive.git] / lang / numpy / Makefile
index b8f3e246ac8bcf2bc4aecf69a5a8f7ceb813a891..4cec5ad6a87d0a22dd3114dd74d61e9243f215d7 100644 (file)
@@ -15,6 +15,7 @@ PKG_SOURCE_URL:=http://downloads.sourceforge.net/numpy/
 PKG_MD5SUM:=8f011e9d7697da570efaac61c51725e0
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/numpy
   SUBMENU:=Python
@@ -22,7 +23,7 @@ define Package/numpy
   CATEGORY:=Languages
   TITLE:=numpy
   URL:=http://numpy.sf.net
-  DEPENDS:=python-core
+  DEPENDS:=python-core @TARGET_x86||TARGET_olpc||TARGET_uml @BROKEN
 endef
 
 define Package/numpy/description
@@ -30,8 +31,7 @@ define Package/numpy/description
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) $(STAGING_DIR)/i386/host/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
-       sed -i "s/UCS4/UCS2/g" $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/numpy/core/multiarray.so
+       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) python2.5 ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
 endef
 
 define Package/numpy/install
@@ -40,3 +40,11 @@ define Package/numpy/install
 endef
 
 $(eval $(call BuildPackage,numpy))
+
+define Require/python25-dev
+[ -e /usr/include/python2.5/pyconfig.h ]
+endef
+
+$(eval $(call Require,python25-dev, \
+       Please install Python 2.5 (including development headers and libraries) \
+))