Add libxcb.
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 29 Dec 2008 23:17:38 +0000 (23:17 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 29 Dec 2008 23:17:38 +0000 (23:17 +0000)
SVN-Revision: 13763

Xorg/lib/libxcb/Makefile [new file with mode: 0644]

diff --git a/Xorg/lib/libxcb/Makefile b/Xorg/lib/libxcb/Makefile
new file mode 100644 (file)
index 0000000..a912994
--- /dev/null
@@ -0,0 +1,112 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 12846 2008-10-03 22:38:55Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libxcb
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://xcb.freedesktop.org/dist/
+PKG_MD5SUM:=
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=xcbproto pthread-stubs
+
+include $(INCLUDE_DIR)/package.mk
+
+
+TARGET_CFLAGS+=\
+       -I$(STAGING_DIR)/usr/lib/libintl/include/
+
+EXTRA_LDFLAGS+=\
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_libxcb CONFIG_PACKAGE_gtk-cups2)
+
+PROTOS:=composite damage dpms glx randr record render res screensaver shape \
+               shm sync xevie xf86dri xfixes xinerama xprint xtest xvmc xv
+
+define Package/libxcb
+  SECTION:=xorg-libs
+  CATEGORY:=Xorg
+  SUBMENU:=lib
+  TITLE:=libxcb
+  DEPENDS:=+libXau +libXdmcp
+endef
+
+define Package/libxcb/description
+libxcb provides an interface to the X Window System protocol, which
+replaces the current Xlib interface.
+endef
+
+define Package/libxcb-xlib
+  SECTION:=xorg-libs
+  CATEGORY:=Xorg
+  SUBMENU:=lib
+  TITLE:=libxcb-proto
+  DEPENDS:=+libxcb
+endef
+
+define Package/libxcb-proto/Default
+define Package/libxcb-$(1)
+  SECTION:=xorg-libs
+  CATEGORY:=Xorg
+  SUBMENU:=lib
+  TITLE:=libxcb-$(1)
+  DEPENDS:=+libxcb
+endef
+endef
+
+$(foreach proto,$(PROTOS),$(eval $(call Package/libxcb-proto/Default,$(proto))))
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/xcb}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/xcb/* \
+               $(1)/usr/include/xcb/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libxcb/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxcb.so* \
+               $(1)/usr/lib/
+endef
+
+define Package/libxcb/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxcb-xlib.so* \
+               $(1)/usr/lib/
+endef
+
+define Package/libxcb-proto/install/Default
+define Package/libxcb-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxcb-$(1).so* \
+               $$(1)/usr/lib/
+endef
+endef
+
+$(foreach proto,$(PROTOS),$(eval $(call Package/libxcb-proto/install/Default,$(proto))))
+
+
+$(eval $(call BuildPackage,libxcb))
+$(eval $(call BuildPackage,libxcb-xlib))
+$(foreach proto,$(PROTOS),$(eval $(call BuildPackage,libxcb-$(proto))))