Somehow update the Makefile template, we do not need to specify PKG_BUILD_DIR or...
[openwrt/svn-archive/archive.git] / libs / jpeg / Makefile
index ff0e9346dd9f9925da46d87b4d0460d375fe2bb3..64b39a979ee47fdfff4540ece472d2346f5931c4 100644 (file)
@@ -17,10 +17,7 @@ PKG_SOURCE_URL:=http://www.ijg.org/files/ \
         ftp://ftp.uu.net/graphics/jpeg/
 PKG_MD5SUM:=dbd5f3b47ed13132f04c685d608a7547
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-PKG_BUILD_DEPENDS:=libtool
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -44,6 +41,8 @@ define Package/jpeg-tools
   TITLE+= manipulation tools
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -58,10 +57,6 @@ define Build/Prepare
        ln -sf /bin/true $(PKG_BUILD_DIR)/ltconfig
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,)
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr/{include,lib,bin,man/man1}