Somehow update the Makefile template, we do not need to specify PKG_BUILD_DIR or...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 11 Nov 2008 14:29:21 +0000 (14:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 11 Nov 2008 14:29:21 +0000 (14:29 +0000)
SVN-Revision: 13181

skels/Makefile.template

index 2676825ecc21103508a3ec46f0c867e8e66db2bb..6ede841b1be0be6b2d818b6474bb1be271d4eef3 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -17,9 +17,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=
 PKG_MD5SUM:=
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/package
@@ -47,7 +44,6 @@ CONFIGURE_VARS += \
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
-
 define Build/Compile
        # pass CFLAGS again to override -O2 set by configure
        $(MAKE) -C $(PKG_BUILD_DIR) \