[packages] ucarp: add dependency on ip instead of messing with busybox default config...
[openwrt/svn-archive/archive.git] / libs / sqlite2 / Makefile
index defce4347a76323b6f101516483248e1b4c05fa1..e2507db1a4427e839f05276d2a811167461b0771 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite2
 PKG_VERSION:=2.8.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=sqlite-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
@@ -18,9 +18,13 @@ PKG_MD5SUM:=838dbac20b56d2c4292e98848505a05b
 PKG_BUILD_DIR:=$(BUILD_DIR)/sqlite-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=libncurses libreadline
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/sqlite2/Default
   SUBMENU:=database
   TITLE:=SQLite (v2.x) database engine
@@ -35,7 +39,6 @@ define Package/libsqlite2
 endef
 
 define Package/libsqlite2/description
-=
        SQLite is a small C library that implements a self-contained, embeddable, 
        zero-configuration SQL database engine. 
        This package contains the SQLite (v2.x) shared library, used by other programs.
@@ -51,7 +54,6 @@ define Package/sqlite2-cli
 endef
 
 define Package/sqlite2-cli/description
-=
        SQLite is a small C library that implements a self-contained, embeddable, 
        zero-configuration SQL database engine. 
        This package contains a terminal-based front-end to the SQLite (v2.x) library 
@@ -74,14 +76,6 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite.h $(1)/usr/include/