[packages] ucarp: add dependency on ip instead of messing with busybox default config...
authorNicolas Thill <nico@openwrt.org>
Sun, 28 Mar 2010 14:55:04 +0000 (14:55 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 28 Mar 2010 14:55:04 +0000 (14:55 +0000)
SVN-Revision: 20543

net/ucarp/Makefile

index 444005fabf24f9a1ee232a5c10a62f0bd7ae2dcc..63051cb01e4d93ef9c73511bc12622bd8e8014ab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucarp
 PKG_VERSION:=1.5.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
@@ -23,7 +23,7 @@ define Package/ucarp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Lets several hosts share one IP
-  DEPENDS:=+libpcap
+  DEPENDS:=+ip +libpcap
   URL:=http://www.ucarp.org/project/ucarp
 endef
 
@@ -37,11 +37,6 @@ define Package/ucarp/conffiles
 /etc/ucarp.conf
 endef
 
-define Package/ucarp/config
-  select BUSYBOX_CONFIG_IP
-  select BUSYBOX_CONFIG_FEATURE_IP_ADDRESS
-endef
-
 define Package/ucarp/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) ./files/ucarp.conf $(1)/etc/