muninlite: Added service file for and dependency on xinetd.
[openwrt/svn-archive/archive.git] / net / arpd / Makefile
index 08498fd3a309efece84fb6162a7fd25b746f46e6..b6e8bff1e31bafae2ca1e6b168ee9fd8e7909e42 100644 (file)
@@ -11,14 +11,12 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=arpd
 PKG_VERSION:=0.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=e2911fa9de1b92ef50deda1489ae944d
 
-PKG_SOURCE_URL:=http://niels.xtdnet.nl/honeyd
+PKG_MD5SUM:=e2911fa9de1b92ef50deda1489ae944d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://niels.xtdnet.nl/honeyd
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,30 +25,31 @@ define Package/arpd
   CATEGORY:=Network
   DEPENDS:=+libpcap +libdnet +libevent
   TITLE:=A daemon to fake ARP replies
-  DESCRIPTION:=A daemon to fake ARP replies
-  URL:=http://niels.xtdnet.nl/honeyd
+  URL:=http://niels.xtdnet.nl/honeyd/
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared --disable-static \
---with-libdnet=$(STAGING_DIR)/usr \
---with-libevent=$(STAGING_DIR)/usr \
---with-libpcap=$(STAGING_DIR)/usr \
-)
+        (cd $(PKG_BUILD_DIR); touch \
+               stamp-h.in \
+               config.h.in \
+       );
+       $(call Build/Configure/Default, \
+               --with-libdnet="$(STAGING_DIR)/usr" \
+               --with-libevent="$(STAGING_DIR)/usr" \
+               --with-libpcap="$(STAGING_DIR)/usr" \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lpcap -ldnet -levent"
+               INCLS="-I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LIBS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpcap -ldnet -levent"
 endef
 
 define Package/arpd/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/arpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,arpd))