muninlite: Added service file for and dependency on xinetd.
authorRod Whitby <rod@whitby.id.au>
Thu, 11 Dec 2008 02:13:23 +0000 (02:13 +0000)
committerRod Whitby <rod@whitby.id.au>
Thu, 11 Dec 2008 02:13:23 +0000 (02:13 +0000)
SVN-Revision: 13589

admin/muninlite/Makefile
admin/muninlite/files/etc/xinetd.d/munin [new file with mode: 0644]

index 4f3a56e0f82f77be237781ac8d322cdfc71a5615..b3b0ee3529d057fb54904c2a5431b8cad1602f0a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=muninlite
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/muninlite
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=
+  DEPENDS:=xinetd
   TITLE:=Munin node implemented in shell
   URL:=http://sourceforge.net/projects/muninlite/
 endef
@@ -33,16 +33,16 @@ endef
 
 define Package/muninlite/postinst
 #!/bin/sh
-grep -q '^munin[[:space:]]*stream' $${IPKG_INSTROOT}/etc/inetd.conf 2>/dev/null
-[ $$? -ne 0 ] && echo "munin   stream  tcp     nowait  root    /usr/sbin/munin-node" >> $${IPKG_INSTROOT}/etc/inetd.conf
 grep -q '^munin[[:space:]]*4949/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "munin     4949/tcp" >> $${IPKG_INSTROOT}/etc/services
+[ $$? -ne 0 ] && echo "munin       4949/tcp" >> $${IPKG_INSTROOT}/etc/services
 exit 0
 endef
 
 define Package/muninlite/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/munin-node $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/xinetd.d
+       $(INSTALL_DATA) ./files/etc/xinetd.d/munin $(1)/etc/xinetd.d/
 endef
 
 define Build/Configure
diff --git a/admin/muninlite/files/etc/xinetd.d/munin b/admin/muninlite/files/etc/xinetd.d/munin
new file mode 100644 (file)
index 0000000..012d71b
--- /dev/null
@@ -0,0 +1,10 @@
+service munin
+{
+       socket_type     = stream
+       protocol        = tcp
+       wait            = no
+       user            = root
+       group           = root
+       server          = /usr/sbin/munin-node
+       disable         = no
+}