[packages] lang: use $(CP) & $(INSTALL_DIR)
[openwrt/svn-archive/archive.git] / net / asterisk-1.6.x / Makefile
index 1172d677b9e158f95007c532b744cf4d7701d429..719840e2b1edcef57d74e70897abdc8a466f6d4e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
-PKG_VERSION:=1.6.1.0-rc3
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.2.0-rc6
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
-PKG_MD5SUM:=29c45a36653e15ef8e78f92a1de753b8
+PKG_MD5SUM:=770a80d306ccc928481ff9030d7fec38
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -89,6 +89,77 @@ $(call Package/asterisk16/Default/description)
  Asterisk.
 endef
 
+define Package/asterisk16-chan-local
+$(call Package/asterisk16/Default)
+  TITLE:=chan_local support
+  DEPENDS:= +asterisk16
+endef
+
+define Package/asterisk16-chan-local/description
+$(call Package/asterisk16/Default/description)
+ This package provides chan_local support to
+ Asterisk.
+endef
+
+define Package/asterisk16-cdr
+$(call Package/asterisk16/Default)
+  TITLE:=CDR support
+  DEPENDS:= +asterisk16
+endef
+
+define Package/asterisk16-cdr/description
+$(call Package/asterisk16/Default/description)
+ This package provides Call Detail Record support to
+ Asterisk.
+endef
+
+define Package/asterisk16-res-musiconhold
+$(call Package/asterisk16/Default)
+  TITLE:=MOH support
+  DEPENDS:= +asterisk16
+endef
+
+define Package/asterisk16-res-musiconhold/description
+$(call Package/asterisk16/Default/description)
+ This package provides Music On Hold support to
+ Asterisk.
+endef
+
+define Package/asterisk16-format-g729
+$(call Package/asterisk16/Default)
+  TITLE:=G.729 support
+  DEPENDS:= +asterisk16
+endef
+
+define Package/asterisk16-format-g729/description
+$(call Package/asterisk16/Default/description)
+ This package provides G.729 support to
+ Asterisk.
+endef
+
+define Package/asterisk16-chan-gtalk
+$(call Package/asterisk16/Default)
+  TITLE:=GTalk support
+  DEPENDS:= +asterisk16 +libiksemel
+endef
+
+define Package/asterisk16-chan-gtalk/description
+$(call Package/asterisk16/Default/description)
+ This package provides the channel chan_gtalk and res_jabber for GTalk
+ support to Asterisk.
+endef
+
+define Package/asterisk16-app-system
+$(call Package/asterisk16/Default)
+  TITLE:=System exec support
+  DEPENDS:= +asterisk16
+endef
+
+define Package/asterisk16-app-system/description
+$(call Package/asterisk16/Default/description)
+ This package provides support for executing system commands in Asterisk.
+endef
+
 CONFIGURE_ARGS+= \
        --without-curl \
        --without-curses \
@@ -118,6 +189,7 @@ CONFIGURE_ARGS+= \
        --without-vorbis \
        --without-vpb \
        --with-z="$(STAGING_DIR)/usr" \
+       --disable-xmldoc \
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk16-app-meetme),)
   CONFIGURE_ARGS+= \
@@ -127,6 +199,19 @@ else
        --without-dahdi
 endif
 
+ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk16-chan-gtalk),)
+  CONFIGURE_ARGS+= \
+       --with-gnutls="$(STAGING_DIR)/usr" \
+       --with-iksemel="$(STAGING_DIR)/usr"
+  SITE_VARS+= \
+       ac_cv_lib_iksemel_iks_start_sasl=yes \
+       ac_cv_lib_gnutls_gnutls_bye=yes
+else
+  CONFIGURE_ARGS+= \
+       --without-gnutls \
+       --without-iksemel
+endif
+
 EXTRA_CFLAGS:= $(TARGET_CPPFLAGS)
 EXTRA_LDFLAGS:= $(TARGET_LDFLAGS)
 
@@ -237,6 +322,19 @@ define Package/asterisk16-chan-iax2/conffiles
 /etc/asterisk/iaxprov.conf
 endef
 
+define Package/asterisk16-cdr/conffiles
+/etc/asterisk/cdr.conf
+/etc/asterisk/cdr_custom.conf
+/etc/asterisk/cdr_manager.conf
+/etc/asterisk/cdr_odbc.conf
+/etc/asterisk/cdr_pgsql.conf
+/etc/asterisk/cdr_tds.conf
+endef
+
+define Package/asterisk16-res-musiconhold/conffiles
+/etc/asterisk/musiconhold.conf
+endef
+
 define Package/asterisk16-chan-iax2/install
        $(INSTALL_DIR) $(1)/etc/asterisk
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/iax.conf $(1)/etc/asterisk/
@@ -245,8 +343,57 @@ define Package/asterisk16-chan-iax2/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_iax2.so $(1)/usr/lib/asterisk/modules/
 endef
 
+define Package/asterisk16-chan-local/install
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_local.so $(1)/usr/lib/asterisk/modules/
+endef
+
+define Package/asterisk16-cdr/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/cdr*.conf $(1)/etc/asterisk/
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/*cdr*.so $(1)/usr/lib/asterisk/modules/
+endef
+
+define Package/asterisk16-res-musiconhold/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/musiconhold.conf $(1)/etc/asterisk/
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_musiconhold.so $(1)/usr/lib/asterisk/modules/
+endef
+
+define Package/asterisk16-format-g729/install
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/format_g729.so $(1)/usr/lib/asterisk/modules/
+endef
+
+define Package/asterisk16-chan-gtalk/conffiles
+/etc/asterisk/gtalk.conf
+/etc/asterisk/jabber.conf
+endef
+
+define Package/asterisk16-chan-gtalk/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/gtalk.conf $(1)/etc/asterisk/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/jabber.conf $(1)/etc/asterisk/
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_gtalk.so $(1)/usr/lib/asterisk/modules/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_jabber.so $(1)/usr/lib/asterisk/modules/
+endef
+
+define Package/asterisk16-app-system/install
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/app_system.so $(1)/usr/lib/asterisk/modules/
+endef
+
 $(eval $(call BuildPackage,asterisk16))
 $(eval $(call BuildPackage,asterisk16-voicemail))
 $(eval $(call BuildPackage,asterisk16-sounds))
 #$(eval $(call BuildPackage,asterisk16-app-meetme))
 $(eval $(call BuildPackage,asterisk16-chan-iax2))
+$(eval $(call BuildPackage,asterisk16-chan-local))
+$(eval $(call BuildPackage,asterisk16-cdr))
+$(eval $(call BuildPackage,asterisk16-res-musiconhold))
+$(eval $(call BuildPackage,asterisk16-format-g729))
+$(eval $(call BuildPackage,asterisk16-chan-gtalk))
+$(eval $(call BuildPackage,asterisk16-app-system))