[packages] lang: use $(CP) & $(INSTALL_DIR)
authorNicolas Thill <nico@openwrt.org>
Fri, 18 Dec 2009 11:00:21 +0000 (11:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 18 Dec 2009 11:00:21 +0000 (11:00 +0000)
SVN-Revision: 18814

lang/ipython/Makefile
lang/logilab-common/Makefile
lang/numpy/Makefile

index 4023fa0c34e16e2ec52427aba8be6a977d943133..dd1a908b314e08a7312b215a603d071280c9a712 100644 (file)
@@ -46,13 +46,13 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 define Package/ipython/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ipython))
index 2fdce18c1f74cbb86b1ff188d218eafcac8d9513..7478f54fd7e176b38903074f158cfac61f8ddab3 100644 (file)
@@ -37,8 +37,8 @@ define Build/Compile
 endef
 
 define Package/logilab-common/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,logilab-common))
index 550b47bdf23862258b649076b6e79f2afed39900..1b2915ee745bdf2c0dd7835c395c0a61a0d20dd2 100644 (file)
@@ -35,8 +35,8 @@ define Build/Compile
 endef
 
 define Package/numpy/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 define Require/python25-dev