[package] update cups to 1.4.2 (#6597)
[openwrt/svn-archive/archive.git] / net / fprobe / Makefile
index f539e96bd9cd0d218f4702b9510f2cd410914d4c..f6be152cc32953a007e7df6bae77a3cbd69e6360 100644 (file)
@@ -4,19 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME := fprobe
-PKG_VERSION := 1.1
-PKG_RELEASE := 1
-PKG_MD5SUM := 65850d0470078269b33eee58cba77ac2
+PKG_NAME:=fprobe
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
 
-PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL := @SF/fprobe
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT := bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/fprobe
+PKG_MD5SUM:=65850d0470078269b33eee58cba77ac2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,17 +22,17 @@ define Package/fprobe
   CATEGORY:=Network
   DEPENDS:=+libpcap +libpthread
   TITLE:=NetFlow probe (libpcap-based)
-  DESCRIPTION:=A NetFlow probe using libpcap
   URL:=http://fprobe.sourceforge.net/
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--with-piddir=/var \
---with-pcap=$(STAGING_DIR)/usr/include \
---with-libpcap=$(STAGING_DIR)/usr/lib \
---with-membulk=index8 \
---with-hash=xor8 \
-)
+       $(call Build/Configure/Default, \
+               --with-piddir=/var \
+               --with-pcap="$(STAGING_DIR)/usr/include" \
+               --with-libpcap="$(STAGING_DIR)/usr/lib" \
+               --with-membulk=index8 \
+               --with-hash=xor8 \
+       )
 endef
 
 define Build/Compile
@@ -43,8 +40,8 @@ define Build/Compile
 endef
 
 define Package/fprobe/install
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe))