[package] update cups to 1.4.2 (#6597)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 19 Mar 2010 18:07:45 +0000 (18:07 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 19 Mar 2010 18:07:45 +0000 (18:07 +0000)
SVN-Revision: 20306

net/cups/Makefile
net/cups/files/etc/cups/cupsd.conf
net/cups/patches/100-makefile-targets.patch
net/cups/patches/130-no_chown.patch [deleted file]
net/cups/patches/160-ppdc.patch [new file with mode: 0644]
net/cups/patches/160-stack-protector.patch [deleted file]

index 87322359c32fa2ac705362a8b38a601ad54fda3d..1a2b969a2c8284640b6a1ab4f7d71c2fa44d33f4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
-PKG_VERSION:=1.3.10
+PKG_VERSION:=1.4.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
        ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-PKG_MD5SUM:=84fffe96b8537c81a463faccead80026
+PKG_MD5SUM:=d95e2d588e3d36e563027a963b117b1b
 
 PKG_BUILD_DEPENDS:=zlib
 
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/cups
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+zlib +libpthread +libpng +libjpeg
+  DEPENDS:=+zlib +libpthread +libpng +libjpeg +libstdcpp
   TITLE:=Common UNIX Printing System
   URL:=http://www.cups.org/
   SUBMENU:=printing
@@ -52,6 +52,7 @@ define Build/Configure
                --without-python \
                --without-php \
                --enable-shared \
+               --enable-image \
                --disable-dbus \
                --disable-pam \
                --disable-slp \
@@ -84,10 +85,12 @@ define Package/cups/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        rm -f $(1)/usr/bin/cups-config
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups*.so* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share/cups/templates
        $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
+       $(INSTALL_DIR) $(1)/usr/share/cups/mime
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/mime/* $(1)/usr/share/cups/mime/
        $(INSTALL_DIR) $(1)/usr/share/doc/cups
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/*.css $(1)/usr/share/doc/cups/
@@ -110,7 +113,7 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/cups $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups*.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,cups))
index 8d7e9d03938b69160bace44bfdb00c6aeb37c32c..0bef5d97a4bebaee16a0f9bb24313d774283ef36 100644 (file)
@@ -34,17 +34,14 @@ Browsing On
 BrowseProtocols cups
 
 <Location />
-AuthType Basic
-AuthClass System
-Order Allow,Deny
-Allow From All
+Order Deny,Allow
+Allow From 127.0.0.1
+Allow From 192.168.1.0/24
 </Location>
 
 <Location /admin>
 AuthType Basic
 AuthClass System
-
 Order Allow,Deny
 Allow From All
 </Location>
-
index 993deef2a5f2c051339ac6cf01dc99f04f18e12a..5d80aaace53b4fddcae56873830ae2bd1e215e64 100644 (file)
@@ -4,10 +4,10 @@
  # Directories to make...
  #
  
--DIRS  =       cups backend berkeley cgi-bin filter locale man monitor \
--              notifier scheduler systemv test \
-+DIRS  =       cups backend berkeley cgi-bin filter monitor \
-+              notifier scheduler systemv \
+-DIRS  =       cups filter backend berkeley cgi-bin driver locale man monitor \
+-              notifier ppdc scheduler systemv test \
++DIRS  =       cups filter backend berkeley cgi-bin driver monitor \
++              ppdc scheduler systemv \
                $(PHPDIR) \
-               conf data doc $(FONTS) ppd templates
+               conf data doc examples $(FONTS) templates
  
diff --git a/net/cups/patches/130-no_chown.patch b/net/cups/patches/130-no_chown.patch
deleted file mode 100644 (file)
index f10fb1e..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/systemv/Makefile
-+++ b/systemv/Makefile
-@@ -70,7 +70,7 @@ install:     all
-       $(INSTALL_BIN) lp $(BINDIR)
-       $(INSTALL_BIN) lpoptions $(BINDIR)
-       $(INSTALL_BIN) lpstat $(BINDIR)
--      $(INSTALL_BIN) -m 4755 -o root lppasswd $(BINDIR) || $(INSTALL_BIN) lppasswd $(BINDIR)
-+      $(INSTALL_BIN) lppasswd $(BINDIR)
-       if test "x$(SYMROOT)" != "x"; then \
-               $(INSTALL_DIR) $(SYMROOT); \
-               for file in $(TARGETS); do \
diff --git a/net/cups/patches/160-ppdc.patch b/net/cups/patches/160-ppdc.patch
new file mode 100644 (file)
index 0000000..54efbe9
--- /dev/null
@@ -0,0 +1,16 @@
+--- cups-1.4.2.orig/ppdc/Makefile      2010-01-28 18:06:41.000000000 +0100
++++ cups-1.4.2/ppdc/Makefile   2010-01-28 20:25:09.000000000 +0100
+@@ -239,12 +239,7 @@
+ genstrings:           genstrings.o libcupsppdc.a ../cups/libcups.a \
+                       sample.drv ../data/media.defs
+-      echo Linking $@...
+-      $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o genstrings genstrings.o \
+-              libcupsppdc.a ../cups/libcups.a $(LIBGSSAPI) $(SSLLIBS) \
+-              $(DNSSDLIBS) $(COMMONLIBS) $(LIBZ)
+-      echo Generating localization strings...
+-      ./genstrings >sample.c
++      echo Not Linking $@...
+ #
diff --git a/net/cups/patches/160-stack-protector.patch b/net/cups/patches/160-stack-protector.patch
deleted file mode 100644 (file)
index 6d5633a..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -10146,59 +10146,6 @@ if test -n "$GCC"; then
-               OPTIM="-fPIC $OPTIM"
-       fi
--      # The -fstack-protector option is available with some versions of
--      # GCC and adds "stack canaries" which detect when the return address
--      # has been overwritten, preventing many types of exploit attacks.
--      { echo "$as_me:$LINENO: checking if GCC supports -fstack-protector" >&5
--echo $ECHO_N "checking if GCC supports -fstack-protector... $ECHO_C" >&6; }
--      OLDCFLAGS="$CFLAGS"
--      CFLAGS="$CFLAGS -fstack-protector"
--      cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h.  */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h.  */
--
--int
--main ()
--{
--
--  ;
--  return 0;
--}
--_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
--  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
--  *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
--  (eval "$ac_compile") 2>conftest.er1
--  ac_status=$?
--  grep -v '^ *+' conftest.er1 >conftest.err
--  rm -f conftest.er1
--  cat conftest.err >&5
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); } && {
--       test -z "$ac_c_werror_flag" ||
--       test ! -s conftest.err
--       } && test -s conftest.$ac_objext; then
--  OPTIM="$OPTIM -fstack-protector"
--              { echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6; }
--else
--  echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--      { echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6; }
--fi
--
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
--      CFLAGS="$OLDCFLAGS"
--
-       # The -pie option is available with some versions of GCC and adds
-       # randomization of addresses, which avoids another class of exploits
-       # that depend on a fixed address for common functions.