[packages] lang: use $(CP) & $(INSTALL_DIR)
[openwrt/svn-archive/archive.git] / net / mercurial / Makefile
index ac0d7dde4dc90dbd634493eb4fa6c57870968b9f..86d7b6e47928f29974ec883b5224384383ae9065 100644 (file)
@@ -1,23 +1,23 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mercurial
-PKG_VERSION:=1.0.2
+PKG_VERSION:=1.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://selenic.com/mercurial/release/
 PKG_SOURCE:=mercurial-$(PKG_VERSION).tar.gz
-#PKG_MD5SUM:=9f8dd7fa6f8886f77be9b923f008504c
-PKG_BUILD_DEPENDS:=python
+PKG_MD5SUM:=4fd3b9a2e5dcd025840c3849b136bec8
+PKG_BUILD_DEPENDS:=python-mini
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/mercurial
   SECTION:=net
@@ -25,25 +25,17 @@ define Package/mercurial
   DEPENDS:=python
   TITLE:=Mercurial Source Control Management (SCM) system
   URL:=http://www.selenic.com/mercurial/
+  SUBMENU:=Version Control Systems
 endef
 
 define Package/mercurial/description
-  DESCRIPTION:=A fast, lightweight Source Control Management system designed for efficient handling of very large distributed projects.
+  A fast, lightweight Source Control Management system designed for efficient handling of very large distributed projects.
 endef
 
-HG_BUILDOPTS= \
-       CC="$(TARGET_CC)" \
-       LDSHARED="$(TARGET_CC) -shared" \
-       CFLAGS="-I$(STAGING_DIR)/usr/include/python2.5/" \
-       LDFLAGS="-L$(STAGING_DIR)/usr/lib -lpython2.5"
-
 define Build/Compile
-       (cd $(PKG_BUILD_DIR); \
-               $(HG_BUILDOPTS) /usr/bin/python setup.py build; \
-       );
-       (cd $(PKG_BUILD_DIR); \
-               /usr/bin/python setup.py install --prefix="$(PKG_INSTALL_DIR)"; \
-       );
+       $(call Build/Compile/PyMod,, \
+               install --prefix="$(PKG_INSTALL_DIR)", \
+    )
 endef
 
 define Package/mercurial/install