Update shorewall to 4.2.1 and fix hostname usage (#4162)
[openwrt/svn-archive/archive.git] / net / rtorrent / Makefile
index ba596a566f6c28a191306599fbfe8608e1d6b524..1048208c9b3bca70cd1ca03cb7064b09005ac36c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
 PKG_VERSION:=0.7.9
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -26,14 +26,14 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx
 endef
 
 define Package/rtorrent/description
      rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
      The client and library are written in C++ with emphasis on speed and
      efficiency, while delivering equivalent features to those found in GUI
      based clients in an ncurses client.
+ rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
+ The client and library are written in C++ with emphasis on speed and
+ efficiency, while delivering equivalent features to those found in GUI
+ based clients in an ncurses client.
 endef
 
 CONFIGURE_ARGS+= \
@@ -42,17 +42,17 @@ CONFIGURE_ARGS+= \
        --disable-debug \
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
-       LIBS="-lm" \
+       LIBS="-lm -luClibc++" \
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Package/rtorrent/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rtorrent $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rtorrent))