Update shorewall to 4.2.1 and fix hostname usage (#4162)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:34:27 +0000 (12:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:34:27 +0000 (12:34 +0000)
SVN-Revision: 13218

net/shorewall-common/Makefile
net/shorewall-common/files/hostname
net/shorewall-shell/Makefile

index 951b4c791299899c24c36ded5fbfd4d82018305d..a9a749150d5e7dce29219abcc0fb6ab8bbdaf9b6 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shorewall-common
-PKG_VERSION:=4.0.13
+PKG_VERSION:=4.2.1
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/4.0/shorewall-$(PKG_VERSION)/
+PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/4.2/shorewall-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=b14dcfcfd9fab234f401e32ecdb2b368
+PKG_MD5SUM:=cd90a367f687977a13403bd5249a6639
 
 include $(INCLUDE_DIR)/package.mk
 
index 1fe1e529503eced74236f67bf16ee2109163248b..42e164371125c92e29571a84fc4621d4ba323dca 100644 (file)
@@ -1,12 +1,2 @@
 #!/bin/sh
-
-. /etc/functions.sh
-hostname="OpenWrt"
-config_cb () {
-       echo a $1
-       config_get hostname "$1" hostname
-       echo b $hostname
-}
-config_load "system"
-
-echo "$hostname"
+cat /proc/sys/kernel/hostname
index 6de9c0570b63bf34106095d193dfbad24cedd380..447b52ea5c6021f5aed036dba50e286a8ce4b28f 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shorewall-shell
-PKG_VERSION:=4.0.13
+PKG_VERSION:=4.2.1
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/4.0/shorewall-$(PKG_VERSION)/
+PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=938f12b6f9345bd1ff820185548a86c3
+PKG_MD5SUM:=7790bb23c7df834549f4f4ec195f37ee
 
 include $(INCLUDE_DIR)/package.mk