Add nbtscan
authorFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:30:53 +0000 (12:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:30:53 +0000 (12:30 +0000)
SVN-Revision: 13217

net/nbtscan/Makefile [new file with mode: 0644]

diff --git a/net/nbtscan/Makefile b/net/nbtscan/Makefile
new file mode 100644 (file)
index 0000000..7db62de
--- /dev/null
@@ -0,0 +1,51 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nbtscan
+PKG_VERSION:=1.5.1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/n/nbtscan/
+PKG_MD5SUM:=
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nbtscan
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=NBTscan is a program for scanning IP networks for NetBIOS name information
+  URL:=http://www.inetcat.net/software/nbtscan.html
+endef
+
+define Package/nbtscan/description
+       NBTscan is a program for scanning IP networks for NetBIOS name information.
+       It sends NetBIOS status query to each address in supplied range and lists
+       received information in human readable form. For each responded host it lists
+       IP address, NetBIOS computer name, logged-in user name and MAC address.
+endef
+
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)"
+endef
+
+
+define Package/nbtscan/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nbtscan $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,nbtscan))