fix conversion to buildroot-ng.
[openwrt/openwrt.git] / openwrt / Makefile
index 9b9d1c955e13db4dcdd30951fb87b042a38b2df0..9b341f1241a8246060e28cc78a0a3fd27a0447e0 100644 (file)
@@ -41,11 +41,11 @@ export OPENWRTVERSION
 all:
 
 .pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif